summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 09:44:02 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 09:57:56 +0100
commitf645c639ea35275ee4639212609fe38323af597d (patch)
treecb92336ba7837a3884252a85303fcd08fa1b9b09 /dev-python/expects/expects-0.8.0.ebuild
parentdev-python/execnet: Remove redundant versions (diff)
downloadgentoo-f645c639ea35275ee4639212609fe38323af597d.tar.gz
gentoo-f645c639ea35275ee4639212609fe38323af597d.tar.bz2
gentoo-f645c639ea35275ee4639212609fe38323af597d.zip
dev-python/expects: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/expects/expects-0.8.0.ebuild')
-rw-r--r--dev-python/expects/expects-0.8.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/expects/expects-0.8.0.ebuild b/dev-python/expects/expects-0.8.0.ebuild
deleted file mode 100644
index 28a0c94321f3..000000000000
--- a/dev-python/expects/expects-0.8.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
-HOMEPAGE="https://github.com/jaimegildesagredo/expects"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/mamba[${PYTHON_USEDEP}] )
-"
-RDEPEND=""
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- mamba || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}