summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-09-21 19:02:10 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-09-21 19:03:26 -0700
commita24551360af1bed102b9186695980a4ca5893776 (patch)
treea5bca5e8a6d438381e2dc0f767ff401bf54087a3 /dev-python/flake8
parentnet-dns/avahi: update openrc init scripts, bug #594622 (diff)
downloadgentoo-a24551360af1bed102b9186695980a4ca5893776.tar.gz
gentoo-a24551360af1bed102b9186695980a4ca5893776.tar.bz2
gentoo-a24551360af1bed102b9186695980a4ca5893776.zip
dev-python/flake8: Fix incorrect mccage dep in DEPEND
This is causing a conflict with itself with FEATURES=test enabled. I discovered this conflict attempting to bump dev-python/treq. Also, with this correction, there is one test failure: > assert parsed_config['ignore'] == ['E123', 'W234', 'E111'] E assert ['# Disable E...e E111\nE111'] == ['E123', 'W234', 'E111'] E At index 0 diff: '# Disable E123\nE123' != 'E123' E Use -v to get the full diff tests/unit/test_merged_config_parser.py:201: AssertionError Package-Manager: portage-2.3.1_p4
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/flake8-3.0.4-r2.ebuild (renamed from dev-python/flake8/flake8-3.0.4-r1.ebuild)16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-python/flake8/flake8-3.0.4-r1.ebuild b/dev-python/flake8/flake8-3.0.4-r2.ebuild
index b80756e3a65f..5b4d64ed2141 100644
--- a/dev-python/flake8/flake8-3.0.4-r1.ebuild
+++ b/dev-python/flake8/flake8-3.0.4-r2.ebuild
@@ -27,21 +27,19 @@ RDEPEND="
<=dev-python/pycodestyle-2.1.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7 pypy )
"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${PDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
- >=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.5[${PYTHON_USEDEP}]
- )"
PDEPEND="
>=dev-python/mccabe-0.5.0[${PYTHON_USEDEP}]
<dev-python/mccabe-0.6[${PYTHON_USEDEP}]
>=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
<=dev-python/pycodestyle-2.1.0[${PYTHON_USEDEP}]
"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )"
python_prepare_all() {
# Gentoo has flake8 support restored in >=pep8-1.6.2-r1.