summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-11-01 11:21:48 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-11-01 11:21:48 -0700
commiteead615859f4f68f0c2eb00ed4dd2be56959ae05 (patch)
tree6cb00f787634420d7bf6c6a0f701221ec3e00290 /dev-python/flake8
parentmedia-libs/mesa: Require libdrm-2.4.87 (diff)
downloadgentoo-eead615859f4f68f0c2eb00ed4dd2be56959ae05.tar.gz
gentoo-eead615859f4f68f0c2eb00ed4dd2be56959ae05.tar.bz2
gentoo-eead615859f4f68f0c2eb00ed4dd2be56959ae05.zip
dev-python/flake8: Version bump to 3.5.0
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-3.5.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index ad2e72977627..859847b21f27 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -4,3 +4,4 @@ DIST flake8-2.2.5.tar.gz 28333 SHA256 285e8bd730c0b6fdfbe23c32d2936bffba401f23ca
DIST flake8-2.5.4.tar.gz 81663 SHA256 cc1e58179f6cf10524c7bfdd378f5536d0a61497688517791639a5ecc867492f SHA512 31cbec556fc41361ac464d2547275e319ab663c907a4a8644113a2288a9f349bcfbec85197b6dfa13a7db9e82419f01e0f2abc84a347e133c144ea137e0daa28 WHIRLPOOL 2547b78092b1a85edd2a0d03d9e0bc31e7d3b7cb3958cf5dea9947377851a69d5c37f64c0d65a5d7e88ab9573597729adbe07ae758b0510e455b26bf62292f47
DIST flake8-3.3.0.tar.gz 134345 SHA256 b907a26dcf5580753d8f80f1be0ec1d5c45b719f7bac441120793d1a70b03f12 SHA512 53b3116765f9031c96a0442954f324fe3edaf63aff21f7cf340e47e724250928d6d9786473d2680b695969ef979a8bb6d4d2b39f1598b075dcace1b221a4c099 WHIRLPOOL 1a0f7e228cbfdde18957c43377fd5c07a280628ca75138e76ec295e5567c153e454543e534496ec9217e7ca0389208ae143c3396ca3798b65b0f2ce1d72bd68b
DIST flake8-3.4.1.tar.gz 137066 SHA256 c20044779ff848f67f89c56a0e4624c04298cd476e25253ac0c36f910a1a11d8 SHA512 42df8fa0cf6f4bb4f3e52143028dee14d51a645aef19a0bab05000fef577e5bea3cc29f961acb0c98d92b76e635fdd2f0d689e23663a6c14d435d0410be94c87 WHIRLPOOL 95be7a58b817d4a7b112104b6f561d3fd30837be6430582856aca6c56d3aff247ec2ae3f3dfc05e29c4ae5b4f0ef0a24a778b30e7813b90234c37c6956970a05
+DIST flake8-3.5.0.tar.gz 140608 SHA256 7253265f7abd8b313e3892944044a365e3f4ac3fcdcfb4298f55ee9ddf188ba0 SHA512 ac5d1bd9c44ed76c9e5cbd941b24bb552aa76e156b24ccda6cc8440ee90f3a574fdb393665adc75298e4f57111d7ab3115ef21ef9088fb327d0a9703d442450c WHIRLPOOL 865a76f752683c9deb1ec0470a15f1031f7ace7ab24e1f8dd54fe608607a1c3916dffb8c7c156d3478272f70f846aa51da8c395730a54c2d6810514b4ae053a4
diff --git a/dev-python/flake8/flake8-3.5.0.ebuild b/dev-python/flake8/flake8-3.5.0.ebuild
new file mode 100644
index 000000000000..128100fc70ea
--- /dev/null
+++ b/dev-python/flake8/flake8-3.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.python.org/pypi/flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ >=dev-python/pyflakes-1.5.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' 'pypy*' )
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' 'python2*' pypy )
+"
+PDEPEND="
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${PDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Flake8 falsely assumes it needs pytest-runner unconditionally and will
+ # try to install it, causing sandbox violations.
+ sed -i -e "/setup_requires=\['pytest-runner'\],/d" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}