summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/flask-dashed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/flask-dashed')
-rw-r--r--dev-python/flask-dashed/Manifest1
-rw-r--r--dev-python/flask-dashed/flask-dashed-0.1b_p2.ebuild33
-rw-r--r--dev-python/flask-dashed/metadata.xml8
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/flask-dashed/Manifest b/dev-python/flask-dashed/Manifest
new file mode 100644
index 000000000000..fb4a197c9627
--- /dev/null
+++ b/dev-python/flask-dashed/Manifest
@@ -0,0 +1 @@
+DIST Flask-Dashed-0.1b2.tar.gz 325834 SHA256 fe49940e39a9eaeafa9d26eb81db0fee1eba54d87ef3a5d7489072cd221c28b0 SHA512 daccb1e4ac83a598c25c7ef202f50f08c19473aa27d8c936a9918b3e45bc9da06de7499a3976e6fff001fd81cec787093594a13c814bf26e2315793a0c8efded WHIRLPOOL e6e520ae230028bf23c1950faf075ccc36cb5bd6b4dfa47f04f39e863943bd75963d51c5f5864dbd50b73bb76505126ff2820a1349beb5af63ff0893e8f0e0bd
diff --git a/dev-python/flask-dashed/flask-dashed-0.1b_p2.ebuild b/dev-python/flask-dashed/flask-dashed-0.1b_p2.ebuild
new file mode 100644
index 000000000000..164c6db17948
--- /dev/null
+++ b/dev-python/flask-dashed/flask-dashed-0.1b_p2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Flask-Dashed"
+MY_PV="${PV/_p/}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Admin app framework for flask"
+HOMEPAGE="http://pythonhosted.org/${MY_PN}/ https://pypi.python.org/pypi/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -rf "${S}/tests"
+}
diff --git a/dev-python/flask-dashed/metadata.xml b/dev-python/flask-dashed/metadata.xml
new file mode 100644
index 000000000000..bdd76fd9f02e
--- /dev/null
+++ b/dev-python/flask-dashed/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Flask-Dashed</remote-id>
+ </upstream>
+</pkgmetadata>