summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 23:29:48 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-04 00:35:13 +0100
commit6a923bd44f93792d5edfeea0194adb8faa478134 (patch)
tree36fce6c6a1786ccaea0636590e918472968dd42f /dev-python/flask-restless
parentdev-python/flask-mongoengine: Clean old up (diff)
downloadgentoo-6a923bd44f93792d5edfeea0194adb8faa478134.tar.gz
gentoo-6a923bd44f93792d5edfeea0194adb8faa478134.tar.bz2
gentoo-6a923bd44f93792d5edfeea0194adb8faa478134.zip
dev-python/flask-restless: Clean old up
Diffstat (limited to 'dev-python/flask-restless')
-rw-r--r--dev-python/flask-restless/Manifest1
-rw-r--r--dev-python/flask-restless/flask-restless-0.15.0.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/flask-restless/Manifest b/dev-python/flask-restless/Manifest
index c8855e92ef5f..cfac42c84c2c 100644
--- a/dev-python/flask-restless/Manifest
+++ b/dev-python/flask-restless/Manifest
@@ -1,2 +1 @@
-DIST flask-restless-0.15.0.tar.gz 515022 BLAKE2B f815380bb384a02f372330460519f9ecdd5cd82ec6ae6bff80fad74e3cfb62aec1a020c46fcd8088f0b4c987e3497e2416ead7586cd7ab9a960fc9cb8b99b8b0 SHA512 156223295a2b1fcb270ed132a9023caa77632559155342381277f427fa069457977f8122bb21425281f1039aaef48c411a5f2677be403a0965abad4af199d775
DIST flask-restless-0.17.0.tar.gz 527502 BLAKE2B 6c82d78fd6c6cc1df43e6858668108abcf862a916c3caf814e0c40a8cd9a9e93a057774d3626c54e47a965d35f8b03408bbe231af01cc7dcf561e0ca02dc4ff3 SHA512 96183a8bb285a916e6ad680089c70b4c00fcc72ea26a6862537314f6b588b597ff78f2f1c3de0ae24f7dfc7af53a3412c8179801afa9eaeaeb3505695d44076e
diff --git a/dev-python/flask-restless/flask-restless-0.15.0.ebuild b/dev-python/flask-restless/flask-restless-0.15.0.ebuild
deleted file mode 100644
index d1ed87369743..000000000000
--- a/dev-python/flask-restless/flask-restless-0.15.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-
-PYTHON_REQ_USE="sqlite"
-inherit distutils-r1
-
-DESCRIPTION="Flask extension for easy ReSTful API generation"
-HOMEPAGE="https://flask-restless.readthedocs.io/ https://github.com/jfinkels/flask-restless"
-SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( AGPL-3 BSD )"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/mimerender[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
- dev-python/flask-themes[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/mapping.patch )
-
-python_compile_all() {
- if use doc; then
- if ! "${PYTHON}" -c "import flask_restless"; then
- eerror "flask-restless is not installed. Building of the docs"
- eerror "requires flask-restless to be installed."
- eerror "emerge with USE=-doc followed bu USE=doc"
- die
- fi
- # Changes connect to read issues @ github
- rm -f docs/changelog.rst
- einfo "Generating html docs for ${PN}"
- PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
- || die "Generating html docs for ${PN} failed"
- fi
-}
-
-python_test() {
- nosetests -w tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}