summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/fudge
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/fudge')
-rw-r--r--dev-python/fudge/Manifest3
-rw-r--r--dev-python/fudge/fudge-0.9.6-r1.ebuild40
-rw-r--r--dev-python/fudge/fudge-1.0.3-r2.ebuild41
-rw-r--r--dev-python/fudge/fudge-1.1.0.ebuild36
-rw-r--r--dev-python/fudge/metadata.xml8
5 files changed, 128 insertions, 0 deletions
diff --git a/dev-python/fudge/Manifest b/dev-python/fudge/Manifest
new file mode 100644
index 000000000000..8ad6cae44a9a
--- /dev/null
+++ b/dev-python/fudge/Manifest
@@ -0,0 +1,3 @@
+DIST fudge-0.9.6.tar.gz 81653 SHA256 34690c4692e8717f4d6a2ab7d841070c93c8d0ea0d2615b47064e291f750b1a0 SHA512 69b2fa5bdd678779c0a8d9863a67e1e6724828720d2764f9f8958bc3598dcf39b22f9827efccb03014961d27d6e214c2125f639bab200b63c824c2306e3bb617 WHIRLPOOL 176df990c9adebe2d4f969603e48b2f1a797cf9935de3daeab98c078314a3fd88a19affdff5b784db5d570a3264f8cc849305b2e4761a7128c2cca7eed79062f
+DIST fudge-1.0.3.tar.gz 87558 SHA256 f8c8bfb3c0199dd06108c0c5a80e3645c7a071e0917b1a3bc73c761800809251 SHA512 7bbbcf517b2570fae20b882467aa7b739fcc9db2cd4fd2c363536da1a2bdd7c016417f42dcdb27c8422213c847eed7d8a90fd9d43eade2a238e5fc62630d5a6a WHIRLPOOL 9e02ea4d849e364ac979bf41c6fc626cdebf4b60186d9b63afe5dafa85ee4c73a9cdfbbc9762dd994e6b909f86f27caf4abe9f44394e203cbe900149f90f7960
+DIST fudge-1.1.0.tar.gz 86418 SHA256 eba59a926fa1df1ab6dddd69a7a8af21865b16cad800cb4d1af75070b0f52afb SHA512 061d9303d28509d4e22eb2036d041359f872be85911dd85bb16e4d13bfc1cf27637f8206f215f4a37d63108ab2500d2af3f6a1a3e206fe461ead9163e0519417 WHIRLPOOL 3425a95652a778b784af99aed54ab90caf3b94fa171c9991e35b5a561ce44e14c2d337c88a3bcd2ea52499dce7d642b70b0be27a45c13fb3d0025abfbbd6d8df
diff --git a/dev-python/fudge/fudge-0.9.6-r1.ebuild b/dev-python/fudge/fudge-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..1992e4aae0df
--- /dev/null
+++ b/dev-python/fudge/fudge-0.9.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Replace real objects with fakes (mocks, stubs, etc) while testing"
+HOMEPAGE="http://farmdev.com/projects/fudge/ http://pypi.python.org/pypi/fudge"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ find -name "._*" -delete || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fudge/fudge-1.0.3-r2.ebuild b/dev-python/fudge/fudge-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..8aae72151784
--- /dev/null
+++ b/dev-python/fudge/fudge-1.0.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Replace real objects with fakes (mocks, stubs, etc) while testing"
+HOMEPAGE="http://farmdev.com/projects/fudge/ http://pypi.python.org/pypi/fudge"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ find -name "._*" -delete || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fudge/fudge-1.1.0.ebuild b/dev-python/fudge/fudge-1.1.0.ebuild
new file mode 100644
index 000000000000..663ac7825fe8
--- /dev/null
+++ b/dev-python/fudge/fudge-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Replace real objects with fakes (mocks, stubs, etc) while testing"
+HOMEPAGE="http://farmdev.com/projects/fudge/ http://pypi.python.org/pypi/fudge"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fudge/metadata.xml b/dev-python/fudge/metadata.xml
new file mode 100644
index 000000000000..c3c08bae4d1b
--- /dev/null
+++ b/dev-python/fudge/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">fudge</remote-id>
+ </upstream>
+</pkgmetadata>