summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-05-24 05:46:44 +0200
committerSam James <sam@gentoo.org>2023-05-27 11:46:41 +0100
commit5719804d6ff6df6f8824193b9899f460cab6eadc (patch)
tree6d8f2be7b56249d929404fb37583579cbf4ea436 /dev-python/future
parentnet-libs/liboauth: modernise (diff)
downloadgentoo-5719804d6ff6df6f8824193b9899f460cab6eadc.tar.gz
gentoo-5719804d6ff6df6f8824193b9899f460cab6eadc.tar.bz2
gentoo-5719804d6ff6df6f8824193b9899f460cab6eadc.zip
dev-python/future: add 0.18.3
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/31151 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/future')
-rw-r--r--dev-python/future/Manifest2
-rw-r--r--dev-python/future/future-0.18.3.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/future/Manifest b/dev-python/future/Manifest
index 4d3885c3e886..d125a5c89a75 100644
--- a/dev-python/future/Manifest
+++ b/dev-python/future/Manifest
@@ -1 +1,3 @@
DIST future-0.18.2.tar.gz 829220 BLAKE2B 68574b589bf54aa8dacbd162a54885589faa32829ccf212f50de5bf036ebd8b9aba0c13e63e80d34e507cc0dae4d8d3d47fea33433b17d2c2e6dbf6c37f66d8f SHA512 91c025f7d94bcdf93df838fab67053165a414fc84e8496f92ecbb910dd55f6b6af5e360bbd051444066880c5a6877e75157bd95e150ead46e5c605930dfc50f2
+DIST future-0.18.3-tests.patch.xz 2736 BLAKE2B 55f9f233fb65f006d2055adf8b5d5b3ab00b4cd9b9f5a78d09b3fa2c1e347ef2d8370569fa5374968bf3e84b4fcbc220ad8da1cc2b32da57c46d36050ba1440a SHA512 c18434bc6efe88381aed8c86ed494352a2749c5680a52f62ae043bec70e3adb0163f91a971daa04134508d59172fe2e71ebbf694a74afce060b7fa1e7c385810
+DIST future-0.18.3.tar.gz 840896 BLAKE2B 13172c639b0eee80581133a2d46b9fa3a38fb9c47ea6eecc8f0715782536be5965bbd153d6a6dda49d8fa9cfea29231c6cc60a4b3b3a6c0cc5406f02c494a425 SHA512 6de56a5aa5c5dd56a0dc5a6732c753530f9868036bd97e9d355f9ee6e1305e266a60c167de779cba93f09b5b3fae615193074caba2afe857ca7ea944532ef910
diff --git a/dev-python/future/future-0.18.3.ebuild b/dev-python/future/future-0.18.3.ebuild
new file mode 100644
index 000000000000..208f5f8ac973
--- /dev/null
+++ b/dev-python/future/future-0.18.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easy, clean, reliable Python 2/3 compatibility"
+HOMEPAGE="
+ https://python-future.org/
+ https://github.com/PythonCharmers/python-future/
+ https://pypi.org/project/future/
+"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-0.18.3-tests.patch.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-0.18.3-tests.patch
+ "${FILESDIR}"/${PN}-0.18.2-py39.patch
+ "${FILESDIR}"/${PN}-0.18.2-py39-fileurl.patch
+ "${FILESDIR}"/${PN}-0.18.2-py3.10.patch
+)
+
+
+EPYTEST_DESELECT=(
+ # tests requiring network access
+ tests/test_future/test_requests.py
+ tests/test_future/test_standard_library.py::TestStandardLibraryReorganization::test_moves_urllib_request_http
+ tests/test_future/test_standard_library.py::TestStandardLibraryReorganization::test_urllib_request_http
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-bootstrap-theme