summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-02 12:43:09 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-02 12:43:32 +0100
commitf42eb166a30db3c7e978ae66aa85b4e7c4cea0f8 (patch)
tree827bcbcad6666d31c77d70971411071820d90535 /dev-python/genty/genty-1.3.2.ebuild
parentdev-python/odfpy: Bump (diff)
downloadgentoo-f42eb166a30db3c7e978ae66aa85b4e7c4cea0f8.tar.gz
gentoo-f42eb166a30db3c7e978ae66aa85b4e7c4cea0f8.tar.bz2
gentoo-f42eb166a30db3c7e978ae66aa85b4e7c4cea0f8.zip
dev-python/genty: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/genty/genty-1.3.2.ebuild')
-rw-r--r--dev-python/genty/genty-1.3.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/genty/genty-1.3.2.ebuild b/dev-python/genty/genty-1.3.2.ebuild
new file mode 100644
index 000000000000..3b83b4580fca
--- /dev/null
+++ b/dev-python/genty/genty-1.3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows you to run a test with multiple data sets"
+HOMEPAGE="https://pypi.python.org/pypi/genty https://github.com/box/genty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# https://github.com/box/genty/issues/42
+RESTRICT=test
+
+python_test() {
+ esetup.py test --verbose
+}