summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/gevent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/gevent')
-rw-r--r--dev-python/gevent/Manifest3
-rw-r--r--dev-python/gevent/gevent-1.0.1.ebuild66
-rw-r--r--dev-python/gevent/gevent-1.0.2.ebuild66
-rw-r--r--dev-python/gevent/gevent-1.0.ebuild66
-rw-r--r--dev-python/gevent/metadata.xml12
5 files changed, 213 insertions, 0 deletions
diff --git a/dev-python/gevent/Manifest b/dev-python/gevent/Manifest
new file mode 100644
index 000000000000..e35130347e87
--- /dev/null
+++ b/dev-python/gevent/Manifest
@@ -0,0 +1,3 @@
+DIST gevent-1.0.1.tar.gz 1455636 SHA256 4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43 SHA512 4790e06b49536ad15856cf551c7ad4d717be2ceda8bc7d39fc35a0132d21f302e033f3294da426be4f6c0476554163776e5ffd82d89962503a720c453ff96461 WHIRLPOOL a1d552f89e9d3db1720fd0db1dbfb6ffc7ed4db87ee5816e5c44843f3c5bba9afbfc21ab2cfcf5bfc84ea70fea3caf6f8fbdbc2807c868b27105bce7e58d6290
+DIST gevent-1.0.2.tar.gz 1735721 SHA256 3ae1ca0f533ddcb17aab16ce66b424b3f3b855ff3b9508526915d3c6b73fba31 SHA512 95b8a24e53ad1ac135e63cb13942c5af6f7efb0fdb4fc2737759d07b09c2408b0d569dd30f63b45a342f81501211e98b5b6116ba9574c8a7801b9c551c14bd53 WHIRLPOOL 402d2af5993a0c04cb0c371190edbd6d4b56bbade2062beb4e7bedb522c0dd32c89452d6d7c1400884043d2f3bcae9ab718a5bccc1d98a563b7b92aeeff38f4e
+DIST gevent-1.0.tar.gz 1437122 SHA256 bfa9d846db91a7d8b6a36e87353eed641c7e3e7d0bfa0b9975796d227f2db4eb SHA512 5f452c799323e8c16172e04a538dfd8ef4066781207ec06ad0bc2d4892a7309b46146e4ab819bf8b99ad4f6ce226d013ded98800efc16458e2626dcc7a77d853 WHIRLPOOL 799fc6402ec3d0e7cc2580d0af8fab06eb01c3cd3dc61e85672e0abb211ba768dea4585ee8a3d204455f19a537974509d992275aaf243ff4948231603b828c6a
diff --git a/dev-python/gevent/gevent-1.0.1.ebuild b/dev-python/gevent/gevent-1.0.1.ebuild
new file mode 100644
index 000000000000..15fd93a5d07d
--- /dev/null
+++ b/dev-python/gevent/gevent-1.0.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python networking library that uses greenlet to provide synchronous API"
+HOMEPAGE="http://gevent.org/ http://pypi.python.org/pypi/gevent/"
+SRC_URI="https://github.com/surfly/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libev
+ net-dns/c-ares
+ >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ rm -r {libev,c-ares} || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd greentest || die
+ "${PYTHON}" testrunner.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ dodoc changelog.rst
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/gevent/gevent-1.0.2.ebuild b/dev-python/gevent/gevent-1.0.2.ebuild
new file mode 100644
index 000000000000..165198ca999a
--- /dev/null
+++ b/dev-python/gevent/gevent-1.0.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python networking library that uses greenlet to provide synchronous API"
+HOMEPAGE="http://gevent.org/ http://pypi.python.org/pypi/gevent/"
+SRC_URI="https://github.com/surfly/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libev
+ net-dns/c-ares
+ >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ rm -r {libev,c-ares} || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd greentest || die
+ "${PYTHON}" testrunner.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ dodoc changelog.rst
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/gevent/gevent-1.0.ebuild b/dev-python/gevent/gevent-1.0.ebuild
new file mode 100644
index 000000000000..e5ac2b973fdd
--- /dev/null
+++ b/dev-python/gevent/gevent-1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python networking library that uses greenlet to provide synchronous API"
+HOMEPAGE="http://gevent.org/ http://pypi.python.org/pypi/gevent/"
+SRC_URI="https://github.com/surfly/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libev
+ net-dns/c-ares
+ >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ rm -r {libev,c-ares} || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd greentest || die
+ "${PYTHON}" testrunner.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ dodoc changelog.rst
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/gevent/metadata.xml b/dev-python/gevent/metadata.xml
new file mode 100644
index 000000000000..e6634865f48a
--- /dev/null
+++ b/dev-python/gevent/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">surfly/gevent</remote-id>
+ </upstream>
+</pkgmetadata>