summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/google-apitools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/google-apitools')
-rw-r--r--dev-python/google-apitools/Manifest2
-rw-r--r--dev-python/google-apitools/google-apitools-0.4.6.ebuild29
-rw-r--r--dev-python/google-apitools/google-apitools-0.4.8.ebuild29
-rw-r--r--dev-python/google-apitools/metadata.xml8
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/google-apitools/Manifest b/dev-python/google-apitools/Manifest
new file mode 100644
index 000000000000..627222057746
--- /dev/null
+++ b/dev-python/google-apitools/Manifest
@@ -0,0 +1,2 @@
+DIST google-apitools-0.4.6.tar.gz 122851 SHA256 1ff89a3b968e83b7fed87e43071decbffa6cfcf8a9adec4342708162b3018d54 SHA512 9b672776b72fba2edd30f2a9cf098dff352dda78075643d55b10187a0ee12e689982c920f76fe4d745ccab829e3ff1fd9818c306ffba20be93020748750e85b4 WHIRLPOOL abd70f06208e1d8b79cfa8b2cf5f01c40f0c520fbd744aa1bb400efd953fc151c0751045b29fdb9ab1610f995d75d640294444fd293a3e6f31fdf3255c0d4dfc
+DIST google-apitools-0.4.8.tar.gz 128587 SHA256 8d4009c5096cc1a8d9be73399bea678035d12c2e67e0d14dd9a9ceded8d771f7 SHA512 28570a050cb7e6c839e39f24908734696a72e05cdb6d84376faf637affd8bf116785411402eddccc1cfa692f753acd82c49ad04ccdce1e4aec66fe2b1b901320 WHIRLPOOL ec0cf908fe10e944199f4b677fd26f2099eb085261f7e2f2ff8441ab77f9cc2fe0fede9dd765fba8e47394f64e402e35fc0ad087af473992b35db665d67bc296
diff --git a/dev-python/google-apitools/google-apitools-0.4.6.ebuild b/dev-python/google-apitools/google-apitools-0.4.6.ebuild
new file mode 100644
index 000000000000..76ef34d211fa
--- /dev/null
+++ b/dev-python/google-apitools/google-apitools-0.4.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="utilities to make it easier to build client-side tools, especially ones that use Google APIs"
+HOMEPAGE="https://github.com/google/apitools"
+SRC_URI="https://github.com/google/apitools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-1.4.8[${PYTHON_USEDEP}]
+ >=dev-python/protorpc-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/google-apputils-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/apitools-${PV}"
diff --git a/dev-python/google-apitools/google-apitools-0.4.8.ebuild b/dev-python/google-apitools/google-apitools-0.4.8.ebuild
new file mode 100644
index 000000000000..76ef34d211fa
--- /dev/null
+++ b/dev-python/google-apitools/google-apitools-0.4.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="utilities to make it easier to build client-side tools, especially ones that use Google APIs"
+HOMEPAGE="https://github.com/google/apitools"
+SRC_URI="https://github.com/google/apitools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-1.4.8[${PYTHON_USEDEP}]
+ >=dev-python/protorpc-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/google-apputils-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/apitools-${PV}"
diff --git a/dev-python/google-apitools/metadata.xml b/dev-python/google-apitools/metadata.xml
new file mode 100644
index 000000000000..3916d6290c35
--- /dev/null
+++ b/dev-python/google-apitools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">google/apitools</remote-id>
+ </upstream>
+</pkgmetadata>