summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-10-25 23:29:53 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-10-25 23:40:31 +0100
commit62a956b92a1c9f95f578a491c2f1eb10c1479ff8 (patch)
tree6f6246f37a69db8d0da4bdbe4745e66aef57a420 /dev-python/gst-python
parentmedia-libs/gst-plugins-bad: add missing introspection USE dependencies (diff)
downloadgentoo-62a956b92a1c9f95f578a491c2f1eb10c1479ff8.tar.gz
gentoo-62a956b92a1c9f95f578a491c2f1eb10c1479ff8.tar.bz2
gentoo-62a956b92a1c9f95f578a491c2f1eb10c1479ff8.zip
dev-python/gst-python: version bump to 1.6
Add support for python3_5. Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/Manifest1
-rw-r--r--dev-python/gst-python/gst-python-1.6.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index 94e920c089f3..f1ebb6b396a0 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -1,3 +1,4 @@
DIST gst-python-0.10.22.tar.bz2 632651 SHA256 8f26f519a5bccd770864317e098e5e307fc5ad1201eb96329634b6508b253178 SHA512 bbbd6b661778cca990da0e216294d86da31a6e472049905989a3311459dd1227bf8f2ae3699a3cdbb66a16288569764352f1e1b93e696d3db4b0728bc38e5b12 WHIRLPOOL c6902554bc8f390b5d295d05598ee60fd6b2637d290125d83a48fc40bbd4e6e261a711430259831c96a30fee4c5ec5c89aea444424b117fb5d62c946b0263454
DIST gst-python-1.2.1.tar.bz2 410887 SHA256 8823e5a9ffc51212df412652da44dc3f2a0e23295da769de2d111c770280efd4 SHA512 ed318d94831d34687224d82b84735984b946c6f33704e6bda56847b633af06212f394b709257007cec5d3a3597b200fbe6b19eade6b76e7855e8668c5ebc270e WHIRLPOOL 959e976c5a481367eb298d24eed4b3bf125d173662ff30cf02506906c88cd369259e0f5cb2bbd31bae31c39934b4a894d2eae13a5e411301f055aef030dcebbb
DIST gst-python-1.4.0.tar.xz 350316 SHA256 b1e40c29ceb41b03f08d38aca6056054f0341d0706276326dceeec6ac8d53d3e SHA512 b970fd16a3b9d82f343fbf20642d165bff25fb815cfe20cc51db8c04c298a8fbd9b96f41811c2d26982eadf1f9a84495c70fbdad553778c68604f828e4773a94 WHIRLPOOL 248d91fc0aac1314c4f7b40866579601a8024c947a29a90b5b6c3585358984f1a50eb6d56aec26609d37fc9144fdf38d5edd7ad61364481d25b7cebfaeff1a96
+DIST gst-python-1.6.0.tar.xz 368100 SHA256 60dbc7f5ac2b6655ed4a7ed2cee63ee5a525d37cb16eaa6b9df7d7dfe4e9605f SHA512 6ca7e274d6aac580aec52d2bc635ffcd1361de73324a2818632d5304d59b71111433f888d89864ee2053ddd71cddec93a1f8dfe511414bd6e3ab2f26e87bfece WHIRLPOOL ef2c990a7949fc9e39b93761f817bba195fc53f314017a7223504930913fe883a6953aa1a3bdb7f1ebd2fef110b3bc2ec6e6e53108ae96125ea8f74a0cfa23e7
diff --git a/dev-python/gst-python/gst-python-1.6.0.ebuild b/dev-python/gst-python/gst-python-1.6.0.ebuild
new file mode 100644
index 000000000000..53128bc120af
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 python{3_3,3_4,3_5} )
+
+inherit python-r1
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libxml2
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-1.6:1.0
+ >=media-libs/gst-plugins-base-1.6:1.0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+# XXX: unittests are not ported to 1.0 yet.
+
+src_prepare() {
+ prepare_gst() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_gst
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ prune_libtool_files --modules
+ einstalldocs
+}