summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2016-01-13 11:46:48 +0100
committerTomas Mozes <hydrapolic@gmail.com>2016-01-13 11:46:48 +0100
commit6fcf85cc22d692721a7c008d5aba28876969787b (patch)
tree5665ed51871731341bb4c406df3f5f85f436ae39 /dev-python/httmock
parentapp-admin/ansible: Fix Version number (diff)
downloadgentoo-6fcf85cc22d692721a7c008d5aba28876969787b.tar.gz
gentoo-6fcf85cc22d692721a7c008d5aba28876969787b.tar.bz2
gentoo-6fcf85cc22d692721a7c008d5aba28876969787b.zip
dev-python/httmock: version bump to 1.2.4
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/httmock')
-rw-r--r--dev-python/httmock/Manifest1
-rw-r--r--dev-python/httmock/httmock-1.2.4.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/httmock/Manifest b/dev-python/httmock/Manifest
index 6eb9009284f9..53bff65e47a2 100644
--- a/dev-python/httmock/Manifest
+++ b/dev-python/httmock/Manifest
@@ -1,2 +1,3 @@
DIST httmock-1.2.2.tar.gz 4975 SHA256 4dd4eddd8dba38c2b279c6fc7487fb92e91b1ae5d945a496bf059ea2b2aaf06c SHA512 0be8ae754bd3ae34166b0b001a44e664b07488ba6d44ed3dc518b310b82418dc5ab2f15ef13cb20909109f19c22a6e13dfdfdfa37f26f3c0688b19f2321be767 WHIRLPOOL 7d1315845e7a72975d5e0f8ae483f17b5e033a230cf020c770e804091c7a0ef5e94c4649720db3f3f5c68d2a19d7a45ab5d696118719967913e4c1ee01f9234c
DIST httmock-1.2.3.tar.gz 5203 SHA256 030cca3f3210b902aaa28524183dc061a2ef9afd3da6a9b40ce0c09d28d50d4d SHA512 23b7295f2685639eba44714b3dadbd6eca20b7f50e636d6490d5c3f581429d84e1f4b1e15f4ba31a7ccee1596768003e68a7f1591b75aeb3d5811b279b3f1bb1 WHIRLPOOL 4eea5a2637e88309a19a05ba5788f8d53a062f0e54458d9ace1e3262affc4104c7953ebceaef52c5fdabcc5b30a520557e75ca5aaa0473159a286d3340200221
+DIST httmock-1.2.4.tar.gz 5412 SHA256 d43f56f0777f0fe8155879c8ede214c55fec56e1c948033ab507915f8d3af761 SHA512 868c38e84665d7eaeae2610d79f21d991f1ddebe72bd9d396a906f59595695199ff2c11c80318e6c246425b9acdb7a1c8b36d570ac0af04d04f4eaa4d965e01b WHIRLPOOL 1f7039840d401cc17303123ca77cc446deb7c811d9e0b861292e2bc0b810c2632efa77e4afa488f7052b553c5d620c2d99191ef48edb33e3e7d3a8fdf2d88515
diff --git a/dev-python/httmock/httmock-1.2.4.ebuild b/dev-python/httmock/httmock-1.2.4.ebuild
new file mode 100644
index 000000000000..3c941d08b27e
--- /dev/null
+++ b/dev-python/httmock/httmock-1.2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A mocking library for requests"
+HOMEPAGE="https://github.com/patrys/httmock"
+SRC_URI="https://github.com/patrys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/requests-1.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}