summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 15:59:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 15:59:55 +0100
commit140b3425ae3ecc8338377eb908581478dccadfbc (patch)
treefd95ea8c5dfbde19862bd9d45a6bf1542074cc22 /dev-python/ipython_genutils
parentdev-python/ipy: Switch to PEP 517 build (diff)
downloadgentoo-140b3425ae3ecc8338377eb908581478dccadfbc.tar.gz
gentoo-140b3425ae3ecc8338377eb908581478dccadfbc.tar.bz2
gentoo-140b3425ae3ecc8338377eb908581478dccadfbc.zip
dev-python/ipython_genutils: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipython_genutils')
-rw-r--r--dev-python/ipython_genutils/ipython_genutils-0.2.0-r3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ipython_genutils/ipython_genutils-0.2.0-r3.ebuild b/dev-python/ipython_genutils/ipython_genutils-0.2.0-r3.ebuild
new file mode 100644
index 000000000000..1f61e977886a
--- /dev/null
+++ b/dev-python/ipython_genutils/ipython_genutils-0.2.0-r3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Vestigial utilities from IPython"
+HOMEPAGE="https://github.com/ipython/ipython_genutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Needed because package provides decorators which use nose
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+distutils_enable_tests nose