summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-03-02 22:06:54 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-03-02 22:06:54 +0700
commitfe9ca10ee7359973da35f459406866ff137591ba (patch)
treee5f530d781d4a562aefbce958e4934516a75bb5c /dev-python/ipython_genutils
parentdev-python/pandocfilters: add python3_8 (diff)
downloadgentoo-fe9ca10ee7359973da35f459406866ff137591ba.tar.gz
gentoo-fe9ca10ee7359973da35f459406866ff137591ba.tar.bz2
gentoo-fe9ca10ee7359973da35f459406866ff137591ba.zip
dev-python/ipython_genutils: add python3_8
Package-Manager: Portage-2.3.91, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/ipython_genutils')
-rw-r--r--dev-python/ipython_genutils/ipython_genutils-0.2.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ipython_genutils/ipython_genutils-0.2.0-r1.ebuild b/dev-python/ipython_genutils/ipython_genutils-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..9036c7d809cd
--- /dev/null
+++ b/dev-python/ipython_genutils/ipython_genutils-0.2.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Vestigial utilities from IPython"
+HOMEPAGE="https://github.com/ipython/ipython_genutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage --cover-package=ipython_genutils ipython_genutils || die
+}