summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/jingo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/jingo')
-rw-r--r--dev-python/jingo/Manifest2
-rw-r--r--dev-python/jingo/jingo-0.7.1.ebuild20
-rw-r--r--dev-python/jingo/jingo-0.7.ebuild20
-rw-r--r--dev-python/jingo/metadata.xml9
4 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/jingo/Manifest b/dev-python/jingo/Manifest
new file mode 100644
index 000000000000..4e90a0e9360f
--- /dev/null
+++ b/dev-python/jingo/Manifest
@@ -0,0 +1,2 @@
+DIST jingo-0.7.1.tar.gz 9982 SHA256 c495a8dfd0a9c1d3d8ed02121bbb28b6c9d34d4da30aa93a7e639c0f3d7b0639 SHA512 153d87f3017b34bb66bddffadb059d0089a48fbdb07bf4881499679c134232be2fe259da95de5a65f6339c1e72a3afb12f4daa1d91ef61f9294bd89899929929 WHIRLPOOL 5fa6af5c5d63766b381413147cc2a0f218693f14350e07f7d8f3e2189fceebd4f6678955aa8fda4ee09799318fc84f533dcc2af761fa0b1a7bb109fbc5dae103
+DIST jingo-0.7.tar.gz 9365 SHA256 a3bd5051dd17e9d50e8a9f2d362508e82d7063010fdc06d5e07ce3608e780fe6 SHA512 7358c20371d761ad147aaa2991056d1789d6a80d645741d816c38369abc469911ca6a1ab4324e7b1243832605fd80cdb3df89610106d2a850f634f1595da254d WHIRLPOOL 5c3c17a287a2cb1469d187387064b8c55accbd240105aa3f09f9fb671512dfb394b3be2529d227181c302070c83c73c1c0556a9885f8cf32ba4dbe31039cfb4d
diff --git a/dev-python/jingo/jingo-0.7.1.ebuild b/dev-python/jingo/jingo-0.7.1.ebuild
new file mode 100644
index 000000000000..1f1c922c242b
--- /dev/null
+++ b/dev-python/jingo/jingo-0.7.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An adapter for using Jinja2 templates with Django"
+HOMEPAGE="http://github.com/jbalogh/jingo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
diff --git a/dev-python/jingo/jingo-0.7.ebuild b/dev-python/jingo/jingo-0.7.ebuild
new file mode 100644
index 000000000000..2ab2dd2cf875
--- /dev/null
+++ b/dev-python/jingo/jingo-0.7.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An adapter for using Jinja2 templates with Django"
+HOMEPAGE="http://github.com/jbalogh/jingo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
diff --git a/dev-python/jingo/metadata.xml b/dev-python/jingo/metadata.xml
new file mode 100644
index 000000000000..122dccb9144f
--- /dev/null
+++ b/dev-python/jingo/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">jingo</remote-id>
+ <remote-id type="github">jbalogh/jingo</remote-id>
+ </upstream>
+</pkgmetadata>