summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-20 20:14:02 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-20 20:15:49 +0100
commit86f10e27826e6a65cbdac044fb3b1651e63b605f (patch)
tree2d787afdd4d5e14fcffd18ae6a33b1fe25c955cc /dev-python/jinja
parentsys-boot/systemd-boot: bump to 235 (diff)
downloadgentoo-86f10e27826e6a65cbdac044fb3b1651e63b605f.tar.gz
gentoo-86f10e27826e6a65cbdac044fb3b1651e63b605f.tar.bz2
gentoo-86f10e27826e6a65cbdac044fb3b1651e63b605f.zip
dev-python/jinja: Version bump to 2.10
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-python/jinja')
-rw-r--r--dev-python/jinja/Manifest1
-rw-r--r--dev-python/jinja/jinja-2.10.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/jinja/Manifest b/dev-python/jinja/Manifest
index e7f53d4d1ebb..810695c76460 100644
--- a/dev-python/jinja/Manifest
+++ b/dev-python/jinja/Manifest
@@ -1,3 +1,4 @@
DIST Jinja2-2.8.tar.gz 357055 SHA256 bc1ff2ff88dbfacefde4ddde471d1417d3b304e8df103a7a9437d47269201bf4 SHA512 2e80d6d9ad10dafcce1e6dd24493f5dffc43a17f71a30a650415638e12d3a3891738ebacc569701129214026d062d91a2b10e4f7a2c7b85d801dde26ded1bebb WHIRLPOOL 31adc38738848aa224cceb0d0afb2b85eb080d166ed84f145eb0576eeedfb91cf8d99d7c98b6a6cc6ab4fedf33fdbe3171c80fd559df48036a7441232702e749
+DIST jinja-2.10.tar.gz 267508 SHA256 0d31d3466c313a9ca014a2d904fed18cdac873a5ba1f7b70b8fd8b206cd860d6 SHA512 bdfd3c4d01b39827c128cbd7f6ebc0ad1434748be41c5037ba1b23156eea1d28f805ffe2a051b4e9b5b38938615c35c8876095b0bf0bed2c139cf5ea49ae2420 WHIRLPOOL 07690d1ab0135bd27a412c1c7999abf52cf4c3500f61e55607b6b0c9a1797b4310cafe53da8dc034fa5600b33c6f494dbb1ed86e942ce2494c1fddf16ea17e98
DIST jinja-2.9.5.tar.gz 486763 SHA256 86baad86b1210856d784ddf0d243b8fa043f65b1e3cbc07e4fb24cd5b9725d89 SHA512 15c1b79981c4d6fcbb7fa947fe0fd7e43973433c03d6549a84deec8ad70881f7fd0d3a35160bf6371361994f838da7eb478c577de2612e004679ae51bd97b121 WHIRLPOOL 8ef540e81c40b72dbf652b73a63577e052813bc3d263340f55181c9a2320fa8e3f65c37ccaa6f4840d79b63c1c47f12070ae76d61be6fe0a93104e3916a7ff36
DIST jinja-2.9.6.tar.gz 487185 SHA256 fa4b0ac374a3502d4523673cfdff7a1f6cbd533a13c8050bef6dcd9168142638 SHA512 934e253d9d621fd6d19302ea5e73b571a806c0e31e10ac29b54700ad6649fabf321b00cdc513bb3fb551ee28e83de7f163ce9ef88d232a6c178f4ee5dc2e69b5 WHIRLPOOL f1f576ff18237ef1dddd76c806d4e9256734aeb289aa146c237803e8fc63984dd41e88e8cdb7f45ff9810d9f20c781f040cc04b2cdd02eacb2c35749e5e257ab
diff --git a/dev-python/jinja/jinja-2.10.ebuild b/dev-python/jinja/jinja-2.10.ebuild
new file mode 100644
index 000000000000..35747dfc21a7
--- /dev/null
+++ b/dev-python/jinja/jinja-2.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A full-featured template engine for Python"
+HOMEPAGE="http://jinja.pocoo.org/ https://pypi.python.org/pypi/Jinja2"
+
+# pypi tarball is missing tests
+SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !dev-python/jinja:compat"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# XXX: handle Babel better?
+
+wrap_opts() {
+ local mydistutilsargs=()
+
+ if [[ ${EPYTHON} == python* ]]; then
+ mydistutilargs+=( --with-debugsupport )
+ fi
+
+ "${@}"
+}
+
+python_compile() {
+ wrap_opts distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ext/Vim/*
+}
+
+pkg_postinst() {
+ if ! has_version dev-python/Babel; then
+ elog "For i18n support, please emerge dev-python/Babel."
+ fi
+}