summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-14 11:38:30 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-14 13:09:57 +0200
commit172ab0c5d942fc83c056fadd61bd6d238d2deaec (patch)
treebb3a7dcbc1ef3de5188065ba75b74b20196b2918 /dev-python/jsonpatch
parentnet-dialup/freeradius-client: Switching to EAPI 7 (diff)
downloadgentoo-172ab0c5d942fc83c056fadd61bd6d238d2deaec.tar.gz
gentoo-172ab0c5d942fc83c056fadd61bd6d238d2deaec.tar.bz2
gentoo-172ab0c5d942fc83c056fadd61bd6d238d2deaec.zip
dev-python/jsonpatch: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpatch')
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.25.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/jsonpatch/jsonpatch-1.25.ebuild b/dev-python/jsonpatch/jsonpatch-1.25.ebuild
index 29d72258211d..a78accbc67f4 100644
--- a/dev-python/jsonpatch/jsonpatch-1.25.ebuild
+++ b/dev-python/jsonpatch/jsonpatch-1.25.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -15,12 +15,12 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
BDEPEND="
test? ( ${RDEPEND} )
"
-RESTRICT="!test? ( test )"
python_test() {
"${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"