summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/mantissa
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/mantissa')
-rw-r--r--dev-python/mantissa/Manifest3
-rw-r--r--dev-python/mantissa/mantissa-0.7.0-r1.ebuild46
-rw-r--r--dev-python/mantissa/mantissa-0.8.0.ebuild52
-rw-r--r--dev-python/mantissa/mantissa-0.8.1.ebuild53
-rw-r--r--dev-python/mantissa/metadata.xml12
5 files changed, 166 insertions, 0 deletions
diff --git a/dev-python/mantissa/Manifest b/dev-python/mantissa/Manifest
new file mode 100644
index 000000000000..d3147080028d
--- /dev/null
+++ b/dev-python/mantissa/Manifest
@@ -0,0 +1,3 @@
+DIST Mantissa-0.7.0.tar.gz 827087 SHA256 30bc3bb452810561e81e84bb73be00287d32c17fcdf4f0da837a63cbba7e7fa7 SHA512 a0ef58902d0d752f2643f0c9639d9338a0441651cc0a2c3b45493a79b81757c4b642a7adcc940e0228033280927b7dad460a345fac62da1dcb9d73babd981d8c WHIRLPOOL 283b02ebea0c7a0d6dd6a7345b473a9f9d0ab3f955c5424ed6090cf50d63f3df2a68b6ab07efe459828a75dc841e5e540a66313e9428bb8e88fb3a96762b6576
+DIST mantissa-0.8.0.tar.gz 828094 SHA256 bcc3908dfe9e8c3dd1a460b2194564d38521d53bcb601f12c9da0a8a936119f1 SHA512 8ca2b84c1c2715025db4a3cde4516c0a8604c8e40bda325d727ac28dbf1997ffb387439461d7b866ec77eb82ca192739355797123e55b7ad30c580b3c71dea9b WHIRLPOOL e4f8858940e87ef0ebbfda522e97da19024dcac18ad59a8d6bac7486aacf05ae728903e8330a845d3a9bc502f3455bb47fe1e6c742d2e09a78621e789c9b680a
+DIST mantissa-0.8.1.tar.gz 808299 SHA256 e0c536a257dad3ee231cc4e1c60bd170d2f2b54dd43cd54a57033d019755ffe3 SHA512 6c5896a0b6d07d0b3c836fcc961240625cca4fe037dd7cb0f105357762a5a5b0288438c39b0aa0521dd7b29a37bde49a739273d82f53c900692d0ea9a8e3db86 WHIRLPOOL 2c4f3c1fcd924afc929e42b74a6e54e6663a4ac82a43e2a3dfdafe2f4ecf6cbd08be96d7e012d3d4410770b0d231c75547ca69731b30e51d1ffde63ac1faa615
diff --git a/dev-python/mantissa/mantissa-0.7.0-r1.ebuild b/dev-python/mantissa/mantissa-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..cece32ac0ce4
--- /dev/null
+++ b/dev-python/mantissa/mantissa-0.7.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="An extensible, multi-protocol, multi-user, interactive application server"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodMantissa http://pypi.python.org/pypi/Mantissa"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=dev-python/axiom-0.6.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/cssutils-0.9.10-r1[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ >=dev-python/nevow-0.10.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2012j[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-mail[${PYTHON_USEDEP}]
+ >=dev-python/vertex-0.3.0-r1[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+TWISTED_PLUGINS=( axiom.plugins nevow.plugins xmantissa.plugins )
+
+python_install() {
+ distutils-r1_python_install
+
+ # remove foreign caches we don't want to own
+ find "${D}$(python_get_sitedir)" -name 'dropin.cache' -delete || die
+ # then our own one
+ touch "${D}$(python_get_sitedir)"/xmantissa/plugins/dropin.cache || die
+}
+
+python_install_all() {
+ dodoc NAME.txt NEWS.txt
+
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ trial xmantissa || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/mantissa/mantissa-0.8.0.ebuild b/dev-python/mantissa/mantissa-0.8.0.ebuild
new file mode 100644
index 000000000000..98ef1ecca4ac
--- /dev/null
+++ b/dev-python/mantissa/mantissa-0.8.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+MY_PN="${PN/m/M}"
+DESCRIPTION="An extensible, multi-protocol, multi-user, interactive application server"
+HOMEPAGE="https://github.com/twisted/mantissa"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/axiom-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/cssutils-0.9.5[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ >=dev-python/nevow-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2012j[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-mail-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-conch-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/vertex-0.2[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+TWISTED_PLUGINS=( axiom.plugins nevow.plugins xmantissa.plugins )
+
+python_test() {
+ # https://github.com/twisted/mantissa/issues/27
+ einfo ""; einfo "suite currently lists 1 failure and 7 errors now known upstream";
+ einfo "A folder with required modules are absent form the source"
+ einfo "All are expected to be fixed in a next release consequent to the bug"
+ einfo "filed upstream, now expected very soon"; einfo ""
+ trial xmantissa || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # remove foreign caches we don't want to own
+ find "${D}$(python_get_sitedir)" -name 'dropin.cache' -delete || die
+ # then our own one
+ touch "${D}$(python_get_sitedir)"/xmantissa/plugins/dropin.cache || die
+}
diff --git a/dev-python/mantissa/mantissa-0.8.1.ebuild b/dev-python/mantissa/mantissa-0.8.1.ebuild
new file mode 100644
index 000000000000..296f013ae235
--- /dev/null
+++ b/dev-python/mantissa/mantissa-0.8.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+MY_PN="${PN/m/M}"
+DESCRIPTION="An extensible, multi-protocol, multi-user, interactive application server"
+HOMEPAGE="https://github.com/twisted/mantissa"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# https://github.com/twisted/mantissa/issues/27
+# Source still missing a folder 'doc' that has required modules and
+# the fail / error rate is far higher then in 0.8.0
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/axiom-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/cssutils-0.9.5[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ >=dev-python/nevow-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2012j[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-mail-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-conch-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/vertex-0.2[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+TWISTED_PLUGINS=( axiom.plugins nevow.plugins xmantissa.plugins )
+
+python_test() {
+ # https://github.com/twisted/mantissa/issues/27
+
+ trial xmantissa || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # remove foreign caches we don't want to own
+ find "${D}$(python_get_sitedir)" -name 'dropin.cache' -delete || die
+ # then our own one
+ touch "${D}$(python_get_sitedir)"/xmantissa/plugins/dropin.cache || die
+}
diff --git a/dev-python/mantissa/metadata.xml b/dev-python/mantissa/metadata.xml
new file mode 100644
index 000000000000..52fe40b7484f
--- /dev/null
+++ b/dev-python/mantissa/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">Mantissa is an application server. It provides integration between
+ the AxiomProject object database, and the TwistedFramework, as well
+ as web user-interface utilities.</longdescription>
+ <upstream>
+ <remote-id type="pypi">Mantissa</remote-id>
+ <remote-id type="github">twisted/mantissa</remote-id>
+ </upstream>
+</pkgmetadata>