summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/mocker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/mocker')
-rw-r--r--dev-python/mocker/Manifest1
-rw-r--r--dev-python/mocker/files/mocker-1.1.1-pypy_test.patch29
-rw-r--r--dev-python/mocker/metadata.xml8
-rw-r--r--dev-python/mocker/mocker-1.1.1-r1.ebuild26
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/mocker/Manifest b/dev-python/mocker/Manifest
new file mode 100644
index 000000000000..067a516c2dae
--- /dev/null
+++ b/dev-python/mocker/Manifest
@@ -0,0 +1 @@
+DIST mocker-1.1.1.tar.bz2 36357 SHA256 2009911707c74b28bdc9959b5224717e45fcb93475b4b7bb4efad3285fcf2919 SHA512 79fc08220b932f5e8ec4999a872fd522a71e2d193fb7842a60b164793863d97aefbd5b16469243c323b8ee151a33e1ea18703b7ceaa239c816bc09a3fb7f6825 WHIRLPOOL 29103b97a278575a424ff46f986459d93751a2865fb1eecfa37134053dfdd03e0998f280b44c43d9c9bd4044b7121b20c191e7dc1989790d774eda653f731619
diff --git a/dev-python/mocker/files/mocker-1.1.1-pypy_test.patch b/dev-python/mocker/files/mocker-1.1.1-pypy_test.patch
new file mode 100644
index 000000000000..b0036ad6dd11
--- /dev/null
+++ b/dev-python/mocker/files/mocker-1.1.1-pypy_test.patch
@@ -0,0 +1,29 @@
+Upstream maintainer assures us "The "assertRaises" line should be skipped IMO. The next call actually succeeds,
+but of course there is no point to test for unsupported functions."
+Re the 2nd patch;
+PyPy actually behaves as if __slots__ was added to the class
+see http://morepypy.blogspot.ch/2010/11/efficiently-implementing-python-objects.html
+diff -ur mocker-1.1.1.orig/test.py mocker-1.1.1/test.py
+--- test.py 2012-05-19 19:27:02.000000000 +0800
++++ test.py 2012-07-11 14:43:57.848953730 +0800
+@@ -3880,7 +3881,7 @@
+ from zlib import adler32
+ # If that fails, this test has to change because either adler32 has
+ # changed, or the implementation of getargspec has changed.
+- self.assertRaises(TypeError, inspect.getargspec, adler32)
++ # self.assertRaises(TypeError, inspect.getargspec, adler32)
+ try:
+ task = SpecChecker(adler32)
+ task.run(self.path("asd"))
+@@ -4060,7 +4060,8 @@
+ self.calendar = calendar
+ obj = C()
+ self.task.replay()
+- self.assertEquals(type(obj.calendar), Mock)
+- self.assertTrue(obj.calendar is self.mock)
++ if not hasattr(sys, 'pypy_version_info'):
++ self.assertEquals(type(obj.calendar), Mock)
++ self.assertTrue(obj.calendar is self.mock)
+
+ def test_install_on_submodule(self):
+ from os import path
diff --git a/dev-python/mocker/metadata.xml b/dev-python/mocker/metadata.xml
new file mode 100644
index 000000000000..ff6fd8b591ac
--- /dev/null
+++ b/dev-python/mocker/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">mocker</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mocker/mocker-1.1.1-r1.ebuild b/dev-python/mocker/mocker-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..ad342178d588
--- /dev/null
+++ b/dev-python/mocker/mocker-1.1.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Platform for Python test doubles: mocks, stubs, fakes, and dummies"
+HOMEPAGE="http://labix.org/mocker http://pypi.python.org/pypi/mocker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-pypy_test.patch )
+
+python_test() {
+ "${PYTHON}" test.py || die "Tests failed under ${EPYTHON}"
+}