summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-10-28 22:30:36 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-10-28 22:56:02 +0200
commitde82a2ba5dd83640b70118f76605fb68eb1ebb69 (patch)
tree359e6f3b6ec861df1e7ce02928bd4d0bf96e6834 /dev-python/nose-testconfig/nose-testconfig-0.10.ebuild
parentdev-python/vulture: Bump (diff)
downloadgentoo-de82a2ba5dd83640b70118f76605fb68eb1ebb69.tar.gz
gentoo-de82a2ba5dd83640b70118f76605fb68eb1ebb69.tar.bz2
gentoo-de82a2ba5dd83640b70118f76605fb68eb1ebb69.zip
dev-python/nose-testconfig: Bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/nose-testconfig/nose-testconfig-0.10.ebuild')
-rw-r--r--dev-python/nose-testconfig/nose-testconfig-0.10.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/nose-testconfig/nose-testconfig-0.10.ebuild b/dev-python/nose-testconfig/nose-testconfig-0.10.ebuild
new file mode 100644
index 000000000000..dfc1abe00abd
--- /dev/null
+++ b/dev-python/nose-testconfig/nose-testconfig-0.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Test Configuration plugin for nosetests"
+HOMEPAGE="https://bitbucket.org/jnoller/nose-testconfig"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="dev-python/nose"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DOCS=( docs/index.txt )
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}