summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-06-17 20:34:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-06-17 20:59:14 -0500
commit7ba8252ee3b7fdeaeb8995ebe9302753bcbf97a5 (patch)
tree8a9130ff2b881aeb50f7532c2a250f1fce39f542 /dev-python/oslo-config
parentdev-python/oslo-messaging: cleanup (diff)
downloadgentoo-7ba8252ee3b7fdeaeb8995ebe9302753bcbf97a5.tar.gz
gentoo-7ba8252ee3b7fdeaeb8995ebe9302753bcbf97a5.tar.bz2
gentoo-7ba8252ee3b7fdeaeb8995ebe9302753bcbf97a5.zip
dev-python/oslo-config: cleanup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/oslo-config')
-rw-r--r--dev-python/oslo-config/Manifest1
-rw-r--r--dev-python/oslo-config/oslo-config-4.11.1.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/oslo-config/Manifest b/dev-python/oslo-config/Manifest
index 2fea99371ac0..dc6552d4ec9e 100644
--- a/dev-python/oslo-config/Manifest
+++ b/dev-python/oslo-config/Manifest
@@ -1,2 +1 @@
-DIST oslo-config-4.11.1.tar.gz 130922 BLAKE2B ab3f142c54a09a3f512614452966f61032ae4f1a0163ac4ffd1aba13b4e2d0c52f597c401a7a0894276aa7a05879a4bfdc1d0a5f0f8fafc6e61b2770d34a6d7d SHA512 c7087080ef336d8aaf262a968495afd599f83528a7eefe6d9d13a819ca4d198964550d516abf4bb674eb4bb95c42e278b65cc9bb8e90ef3d6010e24959d393be
DIST oslo-config-5.2.0.tar.gz 130627 BLAKE2B 7d5e78a7486ea5b24d9eaa488c70c3222da137d230912551e98fdd4a433b3979c2d8841aa4cff3d763ca356ea1f80f2cba13716569ee41e8ff7c4e6511a3d91e SHA512 fa3323926f7f7b1a79e4823dfc102027cb466728500980d9f079c2098c93006b4fdeebb2f09bda41512dc854f5dfe080b727fa2d63910e6fc609d69fab87596c
diff --git a/dev-python/oslo-config/oslo-config-4.11.1.ebuild b/dev-python/oslo-config/oslo-config-4.11.1.ebuild
deleted file mode 100644
index 10b4df1c72e3..000000000000
--- a/dev-python/oslo-config/oslo-config-4.11.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Configuration API"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
- !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- use doc && esetup.py build_sphinx
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- rm -rf .testrepository || die "could not remove '.testrepository' under ${EPTYHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}