summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-18 01:32:11 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-18 01:32:11 -0500
commit9572abf41cba205783d3d5d41a882c07f1cb351a (patch)
tree9f0ac97a5043753d1eeb5e35e4638c832e9cf33a /dev-python/oslo-policy
parentsys-cluster/nova: updating keystoneclient deps (diff)
downloadgentoo-9572abf41cba205783d3d5d41a882c07f1cb351a.tar.gz
gentoo-9572abf41cba205783d3d5d41a882c07f1cb351a.tar.bz2
gentoo-9572abf41cba205783d3d5d41a882c07f1cb351a.zip
dev-python/oslo-policy: adding correct liberty version
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/oslo-policy')
-rw-r--r--dev-python/oslo-policy/Manifest1
-rw-r--r--dev-python/oslo-policy/oslo-policy-0.11.0.ebuild48
-rw-r--r--dev-python/oslo-policy/oslo-policy-0.12.0.ebuild5
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/oslo-policy/Manifest b/dev-python/oslo-policy/Manifest
index 37a962f09291..9e782f2f700b 100644
--- a/dev-python/oslo-policy/Manifest
+++ b/dev-python/oslo-policy/Manifest
@@ -1,2 +1,3 @@
+DIST oslo.policy-0.11.0.tar.gz 34280 SHA256 7aa50cea4db9e26e2cb94f4fa5b42889ad3af70af74fa08bbc15b2c82190c220 SHA512 68593d5d05640d9b505532d03ba8dbf16b121b3d31cdc601ff86abdbfa7e8e2dcbd8a398692ae09496735a7a833a5913e5543cc0a99734b4f40f8b8f0de53f00 WHIRLPOOL ed2ccda20c63173cbb80f009f835348db99819e3371ed7ef3617479e084cc3b8cc1affa39f98dc83aac7237d9d8a506d81a778726a4be2cdfc60cf2e428514cc
DIST oslo.policy-0.12.0.tar.gz 35104 SHA256 5a2319e99a5e6bff310c74222f26a1425e9554c9bf577dcb13ee3cee8c545719 SHA512 b1228d60feb91f8a787915dee46f8944a1c831009b1433ecffc7256f3e1c17efd842d17b69e723b2ff303a05e7a8099f3c9ab1f2fce73a7fd1a5ea552a454c9a WHIRLPOOL 32dcc70a6a4ccd2f9d7ef8742376e40b0bfdb58c15414ca70c46a96d464d62e92a0822f424de0cb615c81ecd07e7e6473203deca7c5c1ddef1151fbec87b5f07
DIST oslo.policy-0.3.2.tar.gz 31745 SHA256 e69a5c559f95bcbf91eb0ea9f16aa65f0fe5fccc7fa03693d4cc991b76e969a6 SHA512 55043f7cbb93799dc53735844d8a315bbdfdba6c83121612737e6125f78e9396f071b2ff6d67133b582228e7e3a36912a4ab02aaa6641ce62f8820a1500bdd99 WHIRLPOOL a93e99f46db150e14327f5a6109dec56993a78c28ef93daa630418685da4d60d1017d8d805ae856eccf8e7553983dec7cc4b87005f12b965a9b4d75348e288e7
diff --git a/dev-python/oslo-policy/oslo-policy-0.11.0.ebuild b/dev-python/oslo-policy/oslo-policy-0.11.0.ebuild
new file mode 100644
index 000000000000..6374d3ca3f59
--- /dev/null
+++ b/dev-python/oslo-policy/oslo-policy-0.11.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4)
+
+inherit distutils-r1
+
+DESCRIPTION="The Oslo Policy library provides support for RBAC policy enforcement across all OpenStack services."
+HOMEPAGE="https://pypi.python.org/pypi/oslo.policy"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.policy/oslo.policy-${PV}.tar.gz"
+S="${WORKDIR}/oslo.policy-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+
+# This time half the doc files are missing; Do you want them?
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}
diff --git a/dev-python/oslo-policy/oslo-policy-0.12.0.ebuild b/dev-python/oslo-policy/oslo-policy-0.12.0.ebuild
index 12021ebdd75b..18ecc1fd94eb 100644
--- a/dev-python/oslo-policy/oslo-policy-0.12.0.ebuild
+++ b/dev-python/oslo-policy/oslo-policy-0.12.0.ebuild
@@ -42,6 +42,11 @@ RDEPEND="
# This time half the doc files are missing; Do you want them?
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
nosetests tests/ || die "test failed under ${EPYTHON}"
}