summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-05-22 15:17:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-05-22 15:18:33 -0500
commit53b7f2f854ae945961573ba96b6b74c9d7df4d53 (patch)
tree7575b60c20bb6fcb956f3d821b8f55b393fc5c75 /dev-python/oslo-rootwrap
parentsys-kernel/ck-sources: v.bump (4.9.29 & 4.11.2) (diff)
downloadgentoo-53b7f2f854ae945961573ba96b6b74c9d7df4d53.tar.gz
gentoo-53b7f2f854ae945961573ba96b6b74c9d7df4d53.tar.bz2
gentoo-53b7f2f854ae945961573ba96b6b74c9d7df4d53.zip
dev-python/oslo-rootwrap: bup 5.4.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/oslo-rootwrap')
-rw-r--r--dev-python/oslo-rootwrap/Manifest1
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-5.4.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/oslo-rootwrap/Manifest b/dev-python/oslo-rootwrap/Manifest
index 48c4008f6c77..70b6b5da9313 100644
--- a/dev-python/oslo-rootwrap/Manifest
+++ b/dev-python/oslo-rootwrap/Manifest
@@ -1 +1,2 @@
DIST oslo.rootwrap-5.4.0.tar.gz 40741 SHA256 8b3c1c5726e0845fcd00d9f951f012bdd3405380acf125428268fba4f70f3c00 SHA512 9848d9f18b7a4063f74d170615b99dc3ebcbcba1ff1f0a10f42b2af9284dd58a65a6b483bed20d176de00170ad60ac7b847cf5a31b950fcd7bf06ecbaecb1823 WHIRLPOOL 0996255270825040156767ae1b08a82aa8df87cabd9122522866ce38e99278c72242d1dfae5e0417267d1dd683b5e3d4ba0d3dcbc75e4449df2a01b267ea24b2
+DIST oslo.rootwrap-5.4.1.tar.gz 42202 SHA256 a76cf545515c1cf6d4d9b1a01a339c1356d1eb78ff3b2190e168dafead3c7e7d SHA512 71980ea266703c7880834cf75b69be9f7bee834a3be314f13ade1bb9903ecf6337237a32a1ed06d020c2fdd3807642af1dd676b6736052d4e57784942782d960 WHIRLPOOL 321a2e9774e3702015510d608e4e145d9fc69c4069865dd5215ad6e94e3692e7e56e029298e908fc007f487d54737d3cd4218dfc93d0625c6950edba45da56b2
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.4.1.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.4.1.ebuild
new file mode 100644
index 000000000000..42e6fb2940bd
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-5.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}