summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 00:45:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:05:07 -0500
commit2fd6a668db90c3dc05b7f9effdfae8f3a5455d1a (patch)
treec99046ae5ed65fdb8cc70ece5c5a4bb57a13d238 /dev-python/oslotest
parentdev-python/oslo-utils: 3.40.3 bump (diff)
downloadgentoo-2fd6a668db90c3dc05b7f9effdfae8f3a5455d1a.tar.gz
gentoo-2fd6a668db90c3dc05b7f9effdfae8f3a5455d1a.tar.bz2
gentoo-2fd6a668db90c3dc05b7f9effdfae8f3a5455d1a.zip
dev-python/oslotest: 3.7.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslotest')
-rw-r--r--dev-python/oslotest/Manifest1
-rw-r--r--dev-python/oslotest/oslotest-3.7.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/oslotest/Manifest b/dev-python/oslotest/Manifest
index 159f93d5c684..d0f1e89d22fe 100644
--- a/dev-python/oslotest/Manifest
+++ b/dev-python/oslotest/Manifest
@@ -1 +1,2 @@
DIST oslotest-3.2.0.tar.gz 35445 BLAKE2B d33c70e760fc595586c2d7b0ce6ed1f63b73c89ba078f85b70d3b6b1af1c4d115e6eb7b431f9ef52abf50290eb47a1d3adb2d014c2ba5cf7b93ecf0e46401a26 SHA512 4513291e2bec939f9734255cb0fe3f85b9eb8a8cadce58873ad4e85365a0ec27bc2084085f5b95b681b5e811b62458e18fe63aff1e022b2d8ace0ca48bd6a527
+DIST oslotest-3.7.1.tar.gz 38176 BLAKE2B 94924dca8384dcc8ba9e4f62220eb6d29b27b38966ffce7dddbd23d5c5e66493141ce4170565325a0516648db186a0171cd33de6d536bb8ed5cdef76161d4f94 SHA512 dfc55bc91ebd8ef448d4c69b2af51b8f2a9f2068b2ef2ec1cfbcfffc27eff7ccafb00dc2a3059730427aecbcd815f9dee2f00b8c74df154c8dbb95793aff7e78
diff --git a/dev-python/oslotest/oslotest-3.7.1.ebuild b/dev-python/oslotest/oslotest-3.7.1.ebuild
new file mode 100644
index 000000000000..235c3c25a36e
--- /dev/null
+++ b/dev-python/oslotest/oslotest-3.7.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo test framework"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx -b man
+ fi
+}
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use doc; then
+ doman doc/build/man/oslotest.1
+ fi
+
+ distutils-r1_python_install_all
+}