summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-10-04 10:29:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-10-04 10:30:15 -0500
commitcf87cd72d8660b7d2994515bf6ee56db0d64e658 (patch)
tree2c6ce1bd584ce2902be6e2ee24f29aff1c85bf4a /dev-python/paste
parentdev-java/reflectasm: version bump. (diff)
downloadgentoo-cf87cd72d8660b7d2994515bf6ee56db0d64e658.tar.gz
gentoo-cf87cd72d8660b7d2994515bf6ee56db0d64e658.tar.bz2
gentoo-cf87cd72d8660b7d2994515bf6ee56db0d64e658.zip
dev-python/paste: fix patch
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/files/paste-2.0.3-unbundle-tempita.patch36
-rw-r--r--dev-python/paste/paste-2.0.3.ebuild1
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/paste/files/paste-2.0.3-unbundle-tempita.patch b/dev-python/paste/files/paste-2.0.3-unbundle-tempita.patch
new file mode 100644
index 000000000000..eef7abb4108e
--- /dev/null
+++ b/dev-python/paste/files/paste-2.0.3-unbundle-tempita.patch
@@ -0,0 +1,36 @@
+ paste/util/looper/__init__.py | 4 ++++
+ paste/util/{looper.py => looper/_looper.py} | 0
+ paste/util/template/__init__.py | 6 ++++++
+ paste/util/{template.py => template/_template.py} | 0
+ 4 files changed, 10 insertions(+)
+
+diff --git a/paste/util/looper/__init__.py b/paste/util/looper/__init__.py
+new file mode 100644
+index 0000000..77d7e80
+--- /dev/null
++++ b/paste/util/looper/__init__.py
+@@ -0,0 +1,4 @@
++try:
++ from tempita._looper import *
++except ImportError:
++ from _looper import *
+diff --git a/paste/util/looper.py b/paste/util/looper/_looper.py
+similarity index 100%
+rename from paste/util/looper.py
+rename to paste/util/looper/_looper.py
+diff --git a/paste/util/template/__init__.py b/paste/util/template/__init__.py
+new file mode 100644
+index 0000000..a0a5730
+--- /dev/null
++++ b/paste/util/template/__init__.py
+@@ -0,0 +1,6 @@
++try:
++ from tempita import *
++ from tempita import paste_script_template_renderer
++except ImportError:
++ from _template import *
++ from _template import paste_script_template_renderer
+diff --git a/paste/util/template.py b/paste/util/template/_template.py
+similarity index 100%
+rename from paste/util/template.py
+rename to paste/util/template/_template.py
diff --git a/dev-python/paste/paste-2.0.3.ebuild b/dev-python/paste/paste-2.0.3.ebuild
index b8cc3cbc58d5..1be0b12b5a9e 100644
--- a/dev-python/paste/paste-2.0.3.ebuild
+++ b/dev-python/paste/paste-2.0.3.ebuild
@@ -44,7 +44,6 @@ python_prepare_all() {
rm -f tests/test_proxy.py || die
local PATCHES=(
- "${FILESDIR}"/${PN}-1.7.5.1-fix-tests-for-pypy.patch
"${FILESDIR}"/${P}-unbundle-tempita.patch
)