summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-21 14:16:13 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-21 15:40:24 +0200
commit515dbbf225912b125854dc9dd9d3ebc8d188b826 (patch)
tree7dcd1fe4ddee934907404c8646aede0ace5095ca /dev-python/pathlib/pathlib-1.0.1-r1.ebuild
parentdev-python/matplotlib: Backported test fix (diff)
downloadgentoo-515dbbf225912b125854dc9dd9d3ebc8d188b826.tar.gz
gentoo-515dbbf225912b125854dc9dd9d3ebc8d188b826.tar.bz2
gentoo-515dbbf225912b125854dc9dd9d3ebc8d188b826.zip
dev-python/pathlib: Don't install existing modules on py3.4
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pathlib/pathlib-1.0.1-r1.ebuild')
-rw-r--r--dev-python/pathlib/pathlib-1.0.1-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/pathlib/pathlib-1.0.1-r1.ebuild b/dev-python/pathlib/pathlib-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..56d014d711dd
--- /dev/null
+++ b/dev-python/pathlib/pathlib-1.0.1-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# In Python 3.4, pathlib is now part of the standard library.
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Object-oriented filesystem paths"
+HOMEPAGE="https://pathlib.readthedocs.org/"
+SRC_URI="mirror://pypi/p/pathlib/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""