summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pbkdf2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pbkdf2')
-rw-r--r--dev-python/pbkdf2/Manifest1
-rw-r--r--dev-python/pbkdf2/metadata.xml16
-rw-r--r--dev-python/pbkdf2/pbkdf2-1.3.ebuild18
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pbkdf2/Manifest b/dev-python/pbkdf2/Manifest
new file mode 100644
index 000000000000..d97cc40669db
--- /dev/null
+++ b/dev-python/pbkdf2/Manifest
@@ -0,0 +1 @@
+DIST pbkdf2-1.3.tar.gz 6360 SHA256 ac6397369f128212c43064a2b4878038dab78dab41875364554aaf2a684e6979 SHA512 1297950d045f9b56f5eb9f771fe65091802c1f12f090a8a80fb5e36bfa10f1c1ac3b9dc8088f4a640b840fb7073aadd3fdf39f3979118046ba5cde477d071244 WHIRLPOOL 85dc9f380d469fc3fe016cb5054c8078dd07d38481df6a7ea51512be238f272dcf1f74a5bed6d5874045edc418913db8d096f355081318803995da5647869a6a
diff --git a/dev-python/pbkdf2/metadata.xml b/dev-python/pbkdf2/metadata.xml
new file mode 100644
index 000000000000..b987fb894b5c
--- /dev/null
+++ b/dev-python/pbkdf2/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer>
+ <email>luke-jr+gentoobugs@utopios.org</email>
+ <name>Luke Dashjr</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pbkdf2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pbkdf2/pbkdf2-1.3.ebuild b/dev-python/pbkdf2/pbkdf2-1.3.ebuild
new file mode 100644
index 000000000000..43ba8c171a9b
--- /dev/null
+++ b/dev-python/pbkdf2/pbkdf2-1.3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Implementation of the password-based key derivation function, PBKDF2, specified in RSA PKCS#5 v2.0"
+HOMEPAGE="http://www.dlitz.net/software/python-pbkdf2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""