summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-05 12:55:40 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-05 12:55:40 +0100
commit583aa7bd68c12f72d63c1b8c48394db4e9c7f3a3 (patch)
tree71de7176ac76ee493e76297b6f4709ff22808262 /dev-python/protobuf-python
parentdev-python/grpcio: Remove old (diff)
downloadgentoo-583aa7bd68c12f72d63c1b8c48394db4e9c7f3a3.tar.gz
gentoo-583aa7bd68c12f72d63c1b8c48394db4e9c7f3a3.tar.bz2
gentoo-583aa7bd68c12f72d63c1b8c48394db4e9c7f3a3.zip
dev-python/protobuf-python: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/Manifest2
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.20.1.ebuild71
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.20.3.ebuild79
3 files changed, 0 insertions, 152 deletions
diff --git a/dev-python/protobuf-python/Manifest b/dev-python/protobuf-python/Manifest
index a24cffb5f6fd..85bcbb4bda71 100644
--- a/dev-python/protobuf-python/Manifest
+++ b/dev-python/protobuf-python/Manifest
@@ -1,3 +1 @@
DIST protobuf-21.9.tar.gz 5110670 BLAKE2B a4f5b7f58e1c5904ca990b100a72992f6f56177b28773f8de8c99e4158391d33cfb8aa8575915887fc9ae4294faf81d4ff6b470bc07b394bfd5885a09ba0fafe SHA512 6954b42d21921e630173b7848c056ab95635627d8eddec960f3db2ddda13eedde00520a9b350722e76e2998649eb8ebe10758e1db938b6a91e38ff3295b1b7c1
-DIST protobuf-3.20.1.tar.gz 5368262 BLAKE2B 1ce1aef2e4c4f3ea4863629cc75d89fe17d0c7ac0c342ac641c787456fd4a12756c2892a27ddadedc94a7201494ec84566638ce33a03cb0c867b04e9eee0edb3 SHA512 fde3eb9f13946887ddfd87df428c5615ad09aaf191e4478b24e98e5e13231feeff4e70b4ca6a2ff7d9b9b2e2c60bc1d5479526edeafa78f9a8ed3bef2e0bacb0
-DIST protobuf-3.20.3.tar.gz 5374320 BLAKE2B fb51f2a0ecf5b83235f5252051f8192ae377bb7a5e030c3f3e9435ccde25919c059830cf476e840fa6c970928a32c0075e213c9d5d4d9e3d3b24732c39a9fbfa SHA512 01d6703bdbe769a1200ee6e4ebcdcb99688ec21f576988c60d82ec36e0822820fb245fcb4ca53293143d53e666d748b5a0c6937bc659fb3cdc4cd9b05ed12a1c
diff --git a/dev-python/protobuf-python/protobuf-python-3.20.1.ebuild b/dev-python/protobuf-python/protobuf-python-3.20.1.ebuild
deleted file mode 100644
index 2b318c1856aa..000000000000
--- a/dev-python/protobuf-python/protobuf-python-3.20.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2008-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf"
- EGIT_SUBMODULES=()
-fi
-
-DESCRIPTION="Google's Protocol Buffers - Python bindings"
-HOMEPAGE="
- https://developers.google.com/protocol-buffers/
- https://github.com/protocolbuffers/protobuf/
- https://pypi.org/project/protobuf/
-"
-if [[ "${PV}" != "9999" ]]; then
- SRC_URI="
- https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz
- -> protobuf-${PV}.tar.gz
- "
-fi
-S="${WORKDIR}/protobuf-${PV}/python"
-
-LICENSE="BSD"
-SLOT="0/30"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-BDEPEND="
- ${PYTHON_DEPS}
- ~dev-libs/protobuf-${PV}
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${PYTHON_DEPS}
- ~dev-libs/protobuf-${PV}
-"
-RDEPEND="
- ${BDEPEND}
- !dev-python/namespace-google
-"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
-fi
-
-distutils_enable_tests setup.py
-
-python_prepare_all() {
- pushd "${WORKDIR}/protobuf-${PV}" > /dev/null || die
- eapply_user
- popd > /dev/null || die
-
- distutils-r1_python_prepare_all
-}
-
-src_configure() {
- DISTUTILS_ARGS=(--cpp_implementation)
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}/install" -name "*.pth" -type f -delete || die
-}
diff --git a/dev-python/protobuf-python/protobuf-python-3.20.3.ebuild b/dev-python/protobuf-python/protobuf-python-3.20.3.ebuild
deleted file mode 100644
index 3b2a8fa16265..000000000000
--- a/dev-python/protobuf-python/protobuf-python-3.20.3.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 2008-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-PARENT_PN="${PN/-python/}"
-PARENT_PV="${PV}"
-PARENT_P="${PARENT_PN}-${PARENT_PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/protocolbuffers/protobuf/archive/v${PARENT_PV}.tar.gz
- -> ${PARENT_P}.tar.gz
- "
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-fi
-
-DESCRIPTION="Google's Protocol Buffers - Python bindings"
-HOMEPAGE="
- https://developers.google.com/protocol-buffers/
- https://pypi.org/project/protobuf/
-"
-
-LICENSE="BSD"
-SLOT="0/31"
-
-S="${WORKDIR}/${PARENT_P}/python"
-
-BDEPEND="
-"
-DEPEND="
- ${PYTHON_DEPS}
-"
-RDEPEND="
- ${BDEPEND}
- dev-libs/protobuf:${SLOT}
-"
-
-distutils_enable_tests setup.py
-
-# Same than PATCHES but from repository's root directory,
-# please see function `python_prepare_all` below.
-# Simplier for users IMHO.
-PARENT_PATCHES=(
-)
-
-# Here for patches within "python/" subdirectory.
-PATCHES=(
- "${FILESDIR}"/${PN}-3.20.3-python311.patch
-)
-
-python_prepare_all() {
- pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
- [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
- eapply_user
- popd > /dev/null || die
-
- distutils-r1_python_prepare_all
-}
-
-src_configure() {
- DISTUTILS_ARGS=( --cpp_implementation )
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}/install" -name "*.pth" -type f -delete || die
-}