summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-01-08 22:24:03 +0100
committerMike Gilbert <floppym@gentoo.org>2018-01-08 16:29:38 -0500
commita782f6268c8b946ab63ac834e9bb38844b610cfc (patch)
tree7a48bbb947d8e2042e6da478de81aa0e58f25911 /dev-python/protobuf-python
parentdev-java/protobuf-java: Version bump (3.5.1.1). (diff)
downloadgentoo-a782f6268c8b946ab63ac834e9bb38844b610cfc.tar.gz
gentoo-a782f6268c8b946ab63ac834e9bb38844b610cfc.tar.bz2
gentoo-a782f6268c8b946ab63ac834e9bb38844b610cfc.zip
dev-python/protobuf-python: Version bump (3.5.1.1).
Closes: https://bugs.gentoo.org/639328
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/Manifest1
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/protobuf-python/Manifest b/dev-python/protobuf-python/Manifest
index 2cf0bd71c2d4..952d4005059a 100644
--- a/dev-python/protobuf-python/Manifest
+++ b/dev-python/protobuf-python/Manifest
@@ -1,2 +1,3 @@
DIST protobuf-3.1.0.tar.gz 4051503 BLAKE2B af93f125a6b7b3e0be6f50ff5eaabe0db21f62b01a694d37c0b069956ef5d658df1beef68514b00a22005a36293b4a8a18654b5656f8c614309f0a744039c2fb SHA512 8d3289a16944c255bd1cceab696e515e52467f2bfe1cc10f6b32fabdf082d5acdc248ec9cadc572223a24d04d431f75921076153109cea2f90ee533f502ab47a
DIST protobuf-3.4.1.tar.gz 4490100 BLAKE2B e2bc1ef2ee1a0af44830b3c65a6c9e73883fe6ec0d07f6a6136f5564f0e85306005440ca6f8c4eb834c7c70f909792c9e2457a761f10f95431981263a9acd7a3 SHA512 471e52198fa878a79183dc8fbc39d9c65239be4d9dff799e12281ee9b1af61a427584534b1baae1773bc6e4c86467f89ca2e7911a21effd86bc5f40cc7d94c34
+DIST protobuf-3.5.1.1.tar.gz 4584489 BLAKE2B 995ee2f06a6358e9935b488269ee50f0dccede417c1757828b0108fbe8c67034301f3a9cb87517430acd9838ae71bb677f4edd8b59b2418f99c15d8ea3d33591 SHA512 f25ecf772facc8efd196b7c06012ce9ec24152b2c0cde38ed2e29ecded8f534221b008e649f4cbd991436ad3436130cd2e31d51e75019d08240d518111fb4496
diff --git a/dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild b/dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild
new file mode 100644
index 000000000000..cb4653d2f74b
--- /dev/null
+++ b/dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+# pypy fails tests; pypy3 fails even running tests
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's Protocol Buffers - Python bindings"
+HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/google/protobuf"
+SRC_URI="https://github.com/google/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !<dev-libs/protobuf-3[python(-)]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/protobuf-${PV}/python"
+
+python_configure_all() {
+ mydistutilsargs=(--cpp_implementation)
+}
+
+python_compile() {
+ python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name "*.pth" -delete || die
+}