summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyamf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyamf')
-rw-r--r--dev-python/pyamf/Manifest1
-rw-r--r--dev-python/pyamf/metadata.xml8
-rw-r--r--dev-python/pyamf/pyamf-0.7.0.ebuild35
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyamf/Manifest b/dev-python/pyamf/Manifest
new file mode 100644
index 000000000000..ab69ca07eff2
--- /dev/null
+++ b/dev-python/pyamf/Manifest
@@ -0,0 +1 @@
+DIST PyAMF-0.7.0.tar.gz 1647988 SHA256 5e9c68a2acc00ee99d1ca1f578c4fc0cbc16e33339a6d5a0d8d313a4c0f42663 SHA512 dcaf808a11c73f9e9b548c9e81100eb28ee1e3c1e2d44b0fb08f58ab3693a49c69b95040e25e612e3864d268436829c4ab7389e1ed9c0704f37a9d350dd9c82d WHIRLPOOL 535fdedea37a866045a34f89b5f255f13d4d3ebc1a1a1fbdba2c233fdd5fedfb1436e4993d69940cbdd5f26898c3d6264afa9bdac21217f38d3d2e955058c369
diff --git a/dev-python/pyamf/metadata.xml b/dev-python/pyamf/metadata.xml
new file mode 100644
index 000000000000..ee77acb0dc1a
--- /dev/null
+++ b/dev-python/pyamf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">hydralabs/pyamf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyamf/pyamf-0.7.0.ebuild b/dev-python/pyamf/pyamf-0.7.0.ebuild
new file mode 100644
index 000000000000..cfccd8feb048
--- /dev/null
+++ b/dev-python/pyamf/pyamf-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=PyAMF
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Action Message Format (AMF) support for Python"
+HOMEPAGE="https://github.com/hydralabs/pyamf"
+SRC_URI="https://github.com/hydralabs/pyamf/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "PyAMF optionally integrates with several third-party libraries"
+ elog "and web frameworks. See the README or the Optional Extras section at"
+ elog "https://github.com/hydralabs/pyamf/blob/master/doc/install.rst"
+ fi
+}