summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-29 21:32:54 +0100
committerMichał Górny <mgorny@gentoo.org>2015-10-29 21:32:54 +0100
commit1869920ea6d1b3b415af43a1225fd68201bf4515 (patch)
tree614779b4fcc0cc6925fe62e287b6d9a8dedf0ae3 /dev-python/pydb
parentdev-db/mariadb: Version bump to 10.0.22 includes security fixes wrt bug 564442 (diff)
downloadgentoo-1869920ea6d1b3b415af43a1225fd68201bf4515.tar.gz
gentoo-1869920ea6d1b3b415af43a1225fd68201bf4515.tar.bz2
gentoo-1869920ea6d1b3b415af43a1225fd68201bf4515.zip
dev-python/pydb: Migrate to python-single-r1
Diffstat (limited to 'dev-python/pydb')
-rw-r--r--dev-python/pydb/pydb-1.26-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pydb/pydb-1.26-r2.ebuild b/dev-python/pydb/pydb-1.26-r2.ebuild
new file mode 100644
index 000000000000..0c3bd07d29a2
--- /dev/null
+++ b/dev-python/pydb/pydb-1.26-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit elisp-common python-single-r1
+
+DESCRIPTION="Extended python debugger"
+HOMEPAGE="http://bashdb.sourceforge.net/pydb/"
+SRC_URI="mirror://sourceforge/bashdb/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+DEPEND="
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix pydb symlinks.
+ sed -e '/$(LN_S) "$(DESTDIR)$(pkgpythondir)\/$(python_debugger_script)" "$(DESTDIR)$(bindir)\/$(bin_SCRIPTS)"/s/$(DESTDIR)$(pkgpythondir)/$(pkgpythondir)/' -i Makefile.in
+}
+
+src_configure() {
+ econf --with-lispdir="${SITELISP}/${PN}" \
+ EMACS="$(usex emacs "${EMACS}" no)" \
+ --with-python="${PYTHON}"
+# --with-site-packages=$(python_get_sitedir) \
+}