summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyenchant
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyenchant')
-rw-r--r--dev-python/pyenchant/Manifest1
-rw-r--r--dev-python/pyenchant/files/pyenchant-setup.patch11
-rw-r--r--dev-python/pyenchant/metadata.xml14
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.6.ebuild31
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyenchant/Manifest b/dev-python/pyenchant/Manifest
new file mode 100644
index 000000000000..5a20ccddc44e
--- /dev/null
+++ b/dev-python/pyenchant/Manifest
@@ -0,0 +1 @@
+DIST pyenchant-1.6.6.tar.gz 64010 SHA256 25c9d2667d512f8fc4410465fdd2e868377ca07eb3d56e2b6e534a86281d64d3 SHA512 af6aa1ac77b5718ec4b4aad3d0b88d26e697b472ec8261b23b37fdbf6b399a120ccc3e4ee6579b884c44b0eeb3f95bcdbceea189105c05088a48400a0c8cdb90 WHIRLPOOL 72f6be0f5012fe467395aa9e55378d1aafcdab45e75d2ea2fb8b9bff9ab6aaccbe36806074381ed7c4703dcc93bcc24caf29830302b8986e89ffc29eb0b5042e
diff --git a/dev-python/pyenchant/files/pyenchant-setup.patch b/dev-python/pyenchant/files/pyenchant-setup.patch
new file mode 100644
index 000000000000..757b759b7146
--- /dev/null
+++ b/dev-python/pyenchant/files/pyenchant-setup.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -6,8 +6,6 @@
+ #
+
+
+-import distribute_setup
+-distribute_setup.use_setuptools()
+ from setuptools import setup, find_packages, Extension
+ from distutils.archive_util import make_archive
+
diff --git a/dev-python/pyenchant/metadata.xml b/dev-python/pyenchant/metadata.xml
new file mode 100644
index 000000000000..9ce38b641ca2
--- /dev/null
+++ b/dev-python/pyenchant/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">PyEnchant is a set of language bindings and some wrapper classes to
+ make the excellent Enchant spellchecker available as a Python
+ module. The bindings are generated using SWIG. It includes all the
+ functionality of Enchant with the flexibility of Python and a nice
+ 'Pythonic' object-oriented interface. It also aims to provide some
+ higher-level functionality than is available in the C API.</longdescription>
+ <upstream>
+ <remote-id type="pypi">pyenchant</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyenchant/pyenchant-1.6.6.ebuild b/dev-python/pyenchant/pyenchant-1.6.6.ebuild
new file mode 100644
index 000000000000..948f2d38430d
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-1.6.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="http://pyenchant.sourceforge.net http://pypi.python.org/pypi/pyenchant"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="
+ >=app-text/enchant-${PV%.*}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ if [[ -n "$(LC_ALL="en_US.UTF-8" bash -c "" 2>&1)" ]]; then
+ ewarn "Disabling tests due to missing en_US.UTF-8 locale"
+ else
+ esetup.py test
+ fi
+}