summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pygsl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pygsl')
-rw-r--r--dev-python/pygsl/Manifest1
-rw-r--r--dev-python/pygsl/metadata.xml12
-rw-r--r--dev-python/pygsl/pygsl-0.9.5-r1.ebuild27
-rw-r--r--dev-python/pygsl/pygsl-0.9.5.ebuild38
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pygsl/Manifest b/dev-python/pygsl/Manifest
new file mode 100644
index 000000000000..d5d95ecb68de
--- /dev/null
+++ b/dev-python/pygsl/Manifest
@@ -0,0 +1 @@
+DIST pygsl-0.9.5.tar.gz 1674504 SHA256 05d11160ff482e1f1f5f6a047aaef2776eedc1e8e1f98533a95299584fd4752d SHA512 7364e67ff2885be2cbe5410a573071209d3917f4807797b3b8525aacd03e6ab96e157e6d12d631c384e3b66602eab7e6cb89f9ab362f520397df900e77fcc875 WHIRLPOOL 404b5f06b1088d047e7afe56311ad9ce0bdcf465ab6961f3cc9d893f575d54c2a103e4c572a60d93e4cf27ee15d4000b7dfbcd6bd33bbc4cf6638749e87f7e24
diff --git a/dev-python/pygsl/metadata.xml b/dev-python/pygsl/metadata.xml
new file mode 100644
index 000000000000..ede9664139ef
--- /dev/null
+++ b/dev-python/pygsl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ PyGSL provides a python interface for the GNU scientific library
+ (gsl).
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pygsl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygsl/pygsl-0.9.5-r1.ebuild b/dev-python/pygsl/pygsl-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..08a36b8a9f68
--- /dev/null
+++ b/dev-python/pygsl/pygsl-0.9.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the GNU scientific library (gsl)"
+HOMEPAGE="http://pygsl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="sci-libs/gsl
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+# Testsuite written to be run post install
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pygsl/pygsl-0.9.5.ebuild b/dev-python/pygsl/pygsl-0.9.5.ebuild
new file mode 100644
index 000000000000..4af265c3ba69
--- /dev/null
+++ b/dev-python/pygsl/pygsl-0.9.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit distutils
+
+DESCRIPTION="Python interface for the GNU scientific library (gsl)"
+HOMEPAGE="http://pygsl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="sci-libs/gsl
+ dev-python/numpy"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ testing() {
+ cd "${S}/tests"
+ PYTHONPATH=$(ls -d ../build-${PYTHON_ABI}/lib*) "$(PYTHON)" run_test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "install examples failed"
+ fi
+}