summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-13 19:08:43 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-13 19:08:43 +0200
commit8337b74ef0d6e8c11fa2d2d4535cf0db24cedbbc (patch)
tree0b17067236a8f8243ef041e7a2bab0ebc7e52386 /dev-python/pyhcl
parentdev-python/pyhcl: Initial version (diff)
downloadgentoo-8337b74ef0d6e8c11fa2d2d4535cf0db24cedbbc.tar.gz
gentoo-8337b74ef0d6e8c11fa2d2d4535cf0db24cedbbc.tar.bz2
gentoo-8337b74ef0d6e8c11fa2d2d4535cf0db24cedbbc.zip
dev-python/pyhcl: Version bump to 0.3.5
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/pyhcl')
-rw-r--r--dev-python/pyhcl/Manifest1
-rw-r--r--dev-python/pyhcl/pyhcl-0.3.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyhcl/Manifest b/dev-python/pyhcl/Manifest
index 4dd36f1f5c50..c3b55f8e73c9 100644
--- a/dev-python/pyhcl/Manifest
+++ b/dev-python/pyhcl/Manifest
@@ -1 +1,2 @@
DIST pyhcl-0.2.3.tar.gz 21796 SHA256 99f49100162a93a746b36903afef964132949f640f5e74c0e0de9106eaf1ac53 SHA512 09cc9dd53048170ad49794d0944acaacba2c08bc5a05bb8d699bb47dc0a03eb32881ddf4dc0771e8b6ee008f7a47b5e95beed4bd77b173c88c6cc322eff4678f WHIRLPOOL 421b4167ff7a2e2e41d9441eb7a17b16b9830ae430c19c03b8c6a2a4b340e0a2039d1551c1b5fda5aefb6cbae522accd03bf2b2e3363d17db0fac78ee4ce113d
+DIST pyhcl-0.3.5.tar.gz 22073 SHA256 3911be54796ea05fc4fa1d19837b4581c8801a8802436d5270ccf6153007d1e7 SHA512 ccd2b669aea0bb5638c0ff410cb4cdb6789fd332b5e2b11fb1ca1da4fc195b479310b39b6e74c45b8e0e940b73c5013f3db514996998c7601efec4e86022a909 WHIRLPOOL cfb68f6dc1704597fea40b495ef3dbf04ad09d38d7254bc873cf0cfbc87d1fcc1fcc114d39328c790051a2e01e624e5bd7993f777031db8d474239422766b341
diff --git a/dev-python/pyhcl/pyhcl-0.3.5.ebuild b/dev-python/pyhcl/pyhcl-0.3.5.ebuild
new file mode 100644
index 000000000000..a21ac72f71bc
--- /dev/null
+++ b/dev-python/pyhcl/pyhcl-0.3.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="HCL configuration parser for python"
+HOMEPAGE="https://github.com/virtuald/pyhcl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/ply-3.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e "s/==.*$//" requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die
+}