summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-19 05:02:05 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-19 05:10:37 +0100
commit2553226f7e245b1f2f992de0f75b6a16781b417c (patch)
treeef13d8b007999c066c0888d16fe59fdc43b3f4ef /dev-python/pykka
parentdev-python/dnspython: Bump to 2.6.1 (diff)
downloadgentoo-2553226f7e245b1f2f992de0f75b6a16781b417c.tar.gz
gentoo-2553226f7e245b1f2f992de0f75b6a16781b417c.tar.bz2
gentoo-2553226f7e245b1f2f992de0f75b6a16781b417c.zip
dev-python/pykka: Bump to 4.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pykka')
-rw-r--r--dev-python/pykka/Manifest1
-rw-r--r--dev-python/pykka/pykka-4.0.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pykka/Manifest b/dev-python/pykka/Manifest
index ca07196bf65e..be43832ade12 100644
--- a/dev-python/pykka/Manifest
+++ b/dev-python/pykka/Manifest
@@ -1 +1,2 @@
DIST pykka-4.0.1.gh.tar.gz 48549 BLAKE2B 4aaeb31b9e9aa9cdc5125719a6a26e9d0b400d5df09bc55d240528bf3623aa46aaf70c2bafb868f8ec82accef239673fd8019571c48341305cac209213ba065c SHA512 fd49250cc641ffcfd3ad71f3716452ef6dbc54e201e56d8fb3d13d8315379058e5648b773327830d1e2eb60fe6a9576aac81d5613cd02af3ce5b42866716e030
+DIST pykka-4.0.2.gh.tar.gz 48536 BLAKE2B 57825e0cbcad0afc33870de000820cfcd400d195715d8c48f133470ab8c9c26d9f8ab1a9cb54e847fe163b240258c789ec70bcf3627dcfbad1d469eee7c2d9c0 SHA512 43d31258f73a6d43c467d108066dd3e852db9e21a04fda030137dbd65052a874e346ed78b79a4929b25d2744a286c95d5d425ae150428ea1594a24f2a6c6a164
diff --git a/dev-python/pykka/pykka-4.0.2.ebuild b/dev-python/pykka/pykka-4.0.2.ebuild
new file mode 100644
index 000000000000..066fbec33863
--- /dev/null
+++ b/dev-python/pykka/pykka-4.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of the actor model"
+HOMEPAGE="
+ https://pykka.org/en/latest/
+ https://github.com/jodal/pykka/
+ https://pypi.org/project/pykka/
+"
+SRC_URI="
+ https://github.com/jodal/pykka/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest