summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-06 18:59:18 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-06 19:18:22 +0100
commit603e42fdbc25c5392d77929005aa185952622476 (patch)
treee34bcd8921367d608ee41b9ae62860d1a5f17687 /dev-python/pykka
parentdev-python/pykka: Remove old (diff)
downloadgentoo-603e42fdbc25c5392d77929005aa185952622476.tar.gz
gentoo-603e42fdbc25c5392d77929005aa185952622476.tar.bz2
gentoo-603e42fdbc25c5392d77929005aa185952622476.zip
dev-python/pykka: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pykka')
-rw-r--r--dev-python/pykka/Manifest1
-rw-r--r--dev-python/pykka/pykka-4.0.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pykka/Manifest b/dev-python/pykka/Manifest
index 14d02ca7b793..6a16c65f8e0b 100644
--- a/dev-python/pykka/Manifest
+++ b/dev-python/pykka/Manifest
@@ -1 +1,2 @@
DIST pykka-4.0.0.gh.tar.gz 48507 BLAKE2B c394f493884b5f6a97d52e1f7038615510cfb1f75ef9f639fb3b1a4feb8ea5206edda6b647fd782fe16902cd1d9d210f168d0846942ed0f1b720a869029c2b34 SHA512 2078df598c23a742a62f374b1de76ba94f671e4af458532ba16245b32579462574c75adebf625aaab0a5875bc9e9803a10d2f8c82f783537ad893b896be00f12
+DIST pykka-4.0.1.gh.tar.gz 48549 BLAKE2B 4aaeb31b9e9aa9cdc5125719a6a26e9d0b400d5df09bc55d240528bf3623aa46aaf70c2bafb868f8ec82accef239673fd8019571c48341305cac209213ba065c SHA512 fd49250cc641ffcfd3ad71f3716452ef6dbc54e201e56d8fb3d13d8315379058e5648b773327830d1e2eb60fe6a9576aac81d5613cd02af3ce5b42866716e030
diff --git a/dev-python/pykka/pykka-4.0.1.ebuild b/dev-python/pykka/pykka-4.0.1.ebuild
new file mode 100644
index 000000000000..01455843e208
--- /dev/null
+++ b/dev-python/pykka/pykka-4.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of the actor model"
+HOMEPAGE="
+ https://pykka.org/en/latest/
+ https://github.com/jodal/pykka/
+ https://pypi.org/project/pykka/
+"
+SRC_URI="
+ https://github.com/jodal/pykka/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest