summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 22:16:01 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 22:16:01 +0100
commit418d17f6ffe7ff1935e46c23b9c95c626e7eac33 (patch)
tree0591524f89cc0abe739d325f31b4cecc137c1933 /dev-python/pymad
parentdev-python/pylibmc: Switch to PEP 517 build (diff)
downloadgentoo-418d17f6ffe7ff1935e46c23b9c95c626e7eac33.tar.gz
gentoo-418d17f6ffe7ff1935e46c23b9c95c626e7eac33.tar.bz2
gentoo-418d17f6ffe7ff1935e46c23b9c95c626e7eac33.zip
dev-python/pymad: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pymad')
-rw-r--r--dev-python/pymad/pymad-0.10-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pymad/pymad-0.10-r1.ebuild b/dev-python/pymad/pymad-0.10-r1.ebuild
new file mode 100644
index 000000000000..f9e7b3d99845
--- /dev/null
+++ b/dev-python/pymad/pymad-0.10-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for libmad MP3 decoding in python"
+HOMEPAGE="https://github.com/jaqx0r/pymad"
+SRC_URI="https://github.com/jaqx0r/${PN}/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-version-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="media-libs/libmad"
+RDEPEND="${DEPEND}"