summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-05-04 12:46:40 +0200
committerIan Delaney <idella4@gentoo.org>2016-05-05 16:06:33 +0800
commit24a1f96e1b07ed068c2c6886a872a20ff7ff7a24 (patch)
tree0f0d110d6d14d127b2dfe15af333a04125db9b48 /dev-python/pymediainfo
parentapp-editors/scite: move updates, changes in vn. 3.6.2 to vns. 3.6.[4,5] (diff)
downloadgentoo-24a1f96e1b07ed068c2c6886a872a20ff7ff7a24.tar.gz
gentoo-24a1f96e1b07ed068c2c6886a872a20ff7ff7a24.tar.bz2
gentoo-24a1f96e1b07ed068c2c6886a872a20ff7ff7a24.zip
dev-python/pymediainfo: bump to 2.1.3, add doc
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1401 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/pymediainfo')
-rw-r--r--dev-python/pymediainfo/Manifest1
-rw-r--r--dev-python/pymediainfo/pymediainfo-2.1.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pymediainfo/Manifest b/dev-python/pymediainfo/Manifest
index 914bcb8cf9ca..88087e37206d 100644
--- a/dev-python/pymediainfo/Manifest
+++ b/dev-python/pymediainfo/Manifest
@@ -1,2 +1,3 @@
DIST pymediainfo-1.4.0.tar.gz 2301 SHA256 d865a79a75d5690af69d31621364ec64b7612a161dfa9b1a84d833a95c1ef19a SHA512 e1e68766340e3a452d672a3ca26d576cc47abad8fc88a4abf28a5be177ce80b8d90d177b44659f01794fbb0c50b2d6c581dbcb07363a09cb872698ec1067988c WHIRLPOOL 9d9a0c6b523253c4e161e6d7388e1e63fbc301d2bd90774fe07b1dbf9eb611acb63228337b0bd2297b99d620473aab8fd086f77354ca25c26395a2f8df37a25d
DIST pymediainfo-2.1.2.tar.gz 420339 SHA256 257d2cd2de1b2da81b2eaf9cda58d40cfcb04704c013d3c38b5edc988996f92f SHA512 51d81289ae9037fc850c58953e5139d4c0cc57dbfa3ecd8daf60b3487bfef2fbb2d2cecefe80b8e8dcad3418e964c8967f27a6f4efcc320d2002b18bcaa9c180 WHIRLPOOL 56ad97804262e30355f453597cae7e0c295db7e3dc656ee33bccd6cdf51bd6aa1a043071f6993c636496c12ae0ad65089c87cec8bdfa32c713c8f02532c00797
+DIST pymediainfo-2.1.3.tar.gz 420494 SHA256 da97c7c000b8b5b641ad56ac3c4458ac05aaced41ad9ac421e78496ca77800df SHA512 b3af87c415fcab12937055cd20cd44779ac49c8f0879af3bd24e541c34f6c2d6160e3c54c315841ade11468dfe64c587d3d66aa67abace3db308bc18ca9121d5 WHIRLPOOL a9799474723b8805bf292fa80ba79cb4e6f4a54b7ffe9c187d27d8403af6b788ddbfef0725d5ecb9474fd9796967868e2ef28db73637beae034444621541a540
diff --git a/dev-python/pymediainfo/pymediainfo-2.1.3.ebuild b/dev-python/pymediainfo/pymediainfo-2.1.3.ebuild
new file mode 100644
index 000000000000..a810b9b92938
--- /dev/null
+++ b/dev-python/pymediainfo/pymediainfo-2.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around the mediainfo library"
+HOMEPAGE="https://github.com/sbraz/pymediainfo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="media-libs/libmediainfo"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests tests || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}