summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyosd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyosd')
-rw-r--r--dev-python/pyosd/Manifest1
-rw-r--r--dev-python/pyosd/metadata.xml5
-rw-r--r--dev-python/pyosd/pyosd-0.2.14-r1.ebuild32
-rw-r--r--dev-python/pyosd/pyosd-0.2.14.ebuild42
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/pyosd/Manifest b/dev-python/pyosd/Manifest
new file mode 100644
index 000000000000..832569692d29
--- /dev/null
+++ b/dev-python/pyosd/Manifest
@@ -0,0 +1 @@
+DIST pyosd-0.2.14.tar.gz 20845 SHA256 a8a52357845f9c84faeab2983f4042b91bbcbb3355d4e70783de7a97aeb3564c SHA512 5781097ec5b082555c5a77953fd939a41d9eaab76fba32a132feec42d01e581f5dcf547fbed13122c56a5778e4b13441ae3d098a9bf7d6db8fac08361ad325a9 WHIRLPOOL 359440f8161d2da66a9319732577b8368f524d3e1636b79a52bb7b286144d86e826db901b7c82e7fd4e7230662744dff01313782bfa178ac81623c1c272a0040
diff --git a/dev-python/pyosd/metadata.xml b/dev-python/pyosd/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/pyosd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pyosd/pyosd-0.2.14-r1.ebuild b/dev-python/pyosd/pyosd-0.2.14-r1.ebuild
new file mode 100644
index 000000000000..34d56bb8ad20
--- /dev/null
+++ b/dev-python/pyosd/pyosd-0.2.14-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for displaying text on your X display, like the 'On Screen Displays' used on TVs"
+HOMEPAGE="http://ichi2.net/pyosd/"
+SRC_URI="http://ichi2.net/pyosd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc examples"
+
+DEPEND=">=x11-libs/xosd-2.2.4"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( pyosd.html )
+ use examples && local EXAMPLES=( modules/. )
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "If you want to run the included daemon, you will need to install dev-python/twisted-core."
+ elog "Also note that the volume plugin requires media-sound/aumix."
+}
diff --git a/dev-python/pyosd/pyosd-0.2.14.ebuild b/dev-python/pyosd/pyosd-0.2.14.ebuild
new file mode 100644
index 000000000000..496a88035375
--- /dev/null
+++ b/dev-python/pyosd/pyosd-0.2.14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="Python module for displaying text on your X display, like the 'On Screen Displays' used on TVs"
+HOMEPAGE="http://ichi2.net/pyosd/"
+SRC_URI="http://ichi2.net/pyosd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86"
+IUSE="examples"
+
+DEPEND=">=x11-libs/xosd-2.2.4"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS"
+
+src_install() {
+ distutils_src_install
+
+ dohtml pyosd.html
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r modules || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "If you want to run the included daemon, you will need to install dev-python/twisted-core."
+ elog "Also note that the volume plugin requires media-sound/aumix."
+}