summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyrfc3339
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyrfc3339')
-rw-r--r--dev-python/pyrfc3339/Manifest1
-rw-r--r--dev-python/pyrfc3339/files/pyrfc3339-0.2-fixdoctests.patch54
-rw-r--r--dev-python/pyrfc3339/metadata.xml9
-rw-r--r--dev-python/pyrfc3339/pyrfc3339-0.2.ebuild32
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/pyrfc3339/Manifest b/dev-python/pyrfc3339/Manifest
new file mode 100644
index 000000000000..a4eab11f920b
--- /dev/null
+++ b/dev-python/pyrfc3339/Manifest
@@ -0,0 +1 @@
+DIST pyRFC3339-0.2.tar.gz 5068 SHA256 a504ff6bcb363fa402d393f65fe5f542475e54fbfc55817b80892ba93b22e6de SHA512 54482528e429c0135823b333d18e6a9361ba99b18a62883e9b09f5533e75f08d12d9c1ee855296cecd98c11824f927984527bb0555a49e4284164b7fe4df8c4f WHIRLPOOL c84d3e1d38b2d57d6525f884a12e8e478aaf6e6e30a00b6267cc5043da9b3b58b1afd585d8350291e32e350df0431be96743b27d95769eecdbc738ded863e68e
diff --git a/dev-python/pyrfc3339/files/pyrfc3339-0.2-fixdoctests.patch b/dev-python/pyrfc3339/files/pyrfc3339-0.2-fixdoctests.patch
new file mode 100644
index 000000000000..1ce4cb02659a
--- /dev/null
+++ b/dev-python/pyrfc3339/files/pyrfc3339-0.2-fixdoctests.patch
@@ -0,0 +1,54 @@
+From 085006c9ffc00d3fba3b91eb33111c791a592715 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Manuel=20R=C3=BCger?= <mrueg@rueg.eu>
+Date: Mon, 13 Jul 2015 20:49:51 +0200
+Subject: [PATCH] Fix doctests for python3
+
+---
+ pyrfc3339/generator.py | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/pyrfc3339/generator.py b/pyrfc3339/generator.py
+index 020d47b..62f88e0 100644
+--- a/pyrfc3339/generator.py
++++ b/pyrfc3339/generator.py
+@@ -9,7 +9,7 @@ def generate(dt, utc=True, accept_naive=False, microseconds=False):
+ :class:`datetime.datetime`.
+
+ >>> from datetime import datetime
+- >>> generate(datetime(2009,01,01,12,59,59,0,pytz.utc))
++ >>> generate(datetime(2009,1,1,12,59,59,0,pytz.utc))
+ '2009-01-01T12:59:59Z'
+
+ The timestamp will use UTC unless `utc=False` is specified, in which case
+@@ -17,7 +17,7 @@ def generate(dt, utc=True, accept_naive=False, microseconds=False):
+ :attr:`tzinfo` parameter.
+
+ >>> eastern = pytz.timezone('US/Eastern')
+- >>> dt = eastern.localize(datetime(2009,01,01,12,59,59))
++ >>> dt = eastern.localize(datetime(2009,1,1,12,59,59))
+ >>> generate(dt)
+ '2009-01-01T17:59:59Z'
+ >>> generate(dt, utc=False)
+@@ -25,19 +25,19 @@ def generate(dt, utc=True, accept_naive=False, microseconds=False):
+
+ Unless `accept_naive=True` is specified, the `datetime` must not be naive.
+
+- >>> generate(datetime(2009,01,01,12,59,59,0))
++ >>> generate(datetime(2009,1,1,12,59,59,0))
+ Traceback (most recent call last):
+ ...
+ ValueError: naive datetime and accept_naive is False
+
+- >>> generate(datetime(2009,01,01,12,59,59,0), accept_naive=True)
++ >>> generate(datetime(2009,1,1,12,59,59,0), accept_naive=True)
+ '2009-01-01T12:59:59Z'
+
+ If `accept_naive=True` is specified, the `datetime` is assumed to be UTC.
+ Attempting to generate a local timestamp from a naive datetime will result
+ in an error.
+
+- >>> generate(datetime(2009,01,01,12,59,59,0), accept_naive=True, utc=False)
++ >>> generate(datetime(2009,1,1,12,59,59,0), accept_naive=True, utc=False)
+ Traceback (most recent call last):
+ ...
+ ValueError: cannot generate a local timestamp from a naive datetime
diff --git a/dev-python/pyrfc3339/metadata.xml b/dev-python/pyrfc3339/metadata.xml
new file mode 100644
index 000000000000..3be1e82eb364
--- /dev/null
+++ b/dev-python/pyrfc3339/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyrfc3339/pyrfc3339-0.2.ebuild b/dev-python/pyrfc3339/pyrfc3339-0.2.ebuild
new file mode 100644
index 000000000000..275f20b65a29
--- /dev/null
+++ b/dev-python/pyrfc3339/pyrfc3339-0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+inherit distutils-r1
+MY_PN=pyRFC3339
+
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Generates and parses RFC 3339 timestamps"
+HOMEPAGE="https://github.com/kurtraschke/pyRFC3339"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=("${FILESDIR}"/${P}-fixdoctests.patch)
+
+python_test() {
+ nosetests || die
+}