summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 14:09:25 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 15:11:05 +0200
commit6bce15254a6bf38cf8fe233e5f9525cfed070c44 (patch)
tree257ba2f702b991dc1633f077205462b8c47826a7 /dev-python/pyrfc3339
parentdev-python/python-oembed: Clean old versions up (diff)
downloadgentoo-6bce15254a6bf38cf8fe233e5f9525cfed070c44.tar.gz
gentoo-6bce15254a6bf38cf8fe233e5f9525cfed070c44.tar.bz2
gentoo-6bce15254a6bf38cf8fe233e5f9525cfed070c44.zip
dev-python/pyrfc3339: Clean old versions up
Diffstat (limited to 'dev-python/pyrfc3339')
-rw-r--r--dev-python/pyrfc3339/Manifest1
-rw-r--r--dev-python/pyrfc3339/files/pyrfc3339-0.2-fixdoctests.patch54
-rw-r--r--dev-python/pyrfc3339/pyrfc3339-0.2.ebuild31
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/pyrfc3339/Manifest b/dev-python/pyrfc3339/Manifest
index fb230cfad202..4121bd637f03 100644
--- a/dev-python/pyrfc3339/Manifest
+++ b/dev-python/pyrfc3339/Manifest
@@ -1,2 +1 @@
-DIST pyRFC3339-0.2.tar.gz 5068 SHA256 a504ff6bcb363fa402d393f65fe5f542475e54fbfc55817b80892ba93b22e6de SHA512 54482528e429c0135823b333d18e6a9361ba99b18a62883e9b09f5533e75f08d12d9c1ee855296cecd98c11824f927984527bb0555a49e4284164b7fe4df8c4f WHIRLPOOL c84d3e1d38b2d57d6525f884a12e8e478aaf6e6e30a00b6267cc5043da9b3b58b1afd585d8350291e32e350df0431be96743b27d95769eecdbc738ded863e68e
DIST pyRFC3339-1.0.tar.gz 9325 SHA256 8dfbc6c458b8daba1c0f3620a8c78008b323a268b27b7359e92a4ae41325f535 SHA512 abcfcfcf516ab60214dc11de618d37415da2177387f51f85da99ef18b8cc0d37ed55f0ea6ba3e61292ce5a319838f322e01c1c9f3c0c4edb8341b4b135e575e3 WHIRLPOOL e85e475b309c806d133cbde24508cd4e57cb9a8da31c83b8b880aac64acfe577545e48d7fc70b5d6f5a6ea85d813ae72fbb98c54faf534bad5b5750bdf573c5b
diff --git a/dev-python/pyrfc3339/files/pyrfc3339-0.2-fixdoctests.patch b/dev-python/pyrfc3339/files/pyrfc3339-0.2-fixdoctests.patch
deleted file mode 100644
index 1ce4cb02659a..000000000000
--- a/dev-python/pyrfc3339/files/pyrfc3339-0.2-fixdoctests.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 085006c9ffc00d3fba3b91eb33111c791a592715 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Manuel=20R=C3=BCger?= <mrueg@rueg.eu>
-Date: Mon, 13 Jul 2015 20:49:51 +0200
-Subject: [PATCH] Fix doctests for python3
-
----
- pyrfc3339/generator.py | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/pyrfc3339/generator.py b/pyrfc3339/generator.py
-index 020d47b..62f88e0 100644
---- a/pyrfc3339/generator.py
-+++ b/pyrfc3339/generator.py
-@@ -9,7 +9,7 @@ def generate(dt, utc=True, accept_naive=False, microseconds=False):
- :class:`datetime.datetime`.
-
- >>> from datetime import datetime
-- >>> generate(datetime(2009,01,01,12,59,59,0,pytz.utc))
-+ >>> generate(datetime(2009,1,1,12,59,59,0,pytz.utc))
- '2009-01-01T12:59:59Z'
-
- The timestamp will use UTC unless `utc=False` is specified, in which case
-@@ -17,7 +17,7 @@ def generate(dt, utc=True, accept_naive=False, microseconds=False):
- :attr:`tzinfo` parameter.
-
- >>> eastern = pytz.timezone('US/Eastern')
-- >>> dt = eastern.localize(datetime(2009,01,01,12,59,59))
-+ >>> dt = eastern.localize(datetime(2009,1,1,12,59,59))
- >>> generate(dt)
- '2009-01-01T17:59:59Z'
- >>> generate(dt, utc=False)
-@@ -25,19 +25,19 @@ def generate(dt, utc=True, accept_naive=False, microseconds=False):
-
- Unless `accept_naive=True` is specified, the `datetime` must not be naive.
-
-- >>> generate(datetime(2009,01,01,12,59,59,0))
-+ >>> generate(datetime(2009,1,1,12,59,59,0))
- Traceback (most recent call last):
- ...
- ValueError: naive datetime and accept_naive is False
-
-- >>> generate(datetime(2009,01,01,12,59,59,0), accept_naive=True)
-+ >>> generate(datetime(2009,1,1,12,59,59,0), accept_naive=True)
- '2009-01-01T12:59:59Z'
-
- If `accept_naive=True` is specified, the `datetime` is assumed to be UTC.
- Attempting to generate a local timestamp from a naive datetime will result
- in an error.
-
-- >>> generate(datetime(2009,01,01,12,59,59,0), accept_naive=True, utc=False)
-+ >>> generate(datetime(2009,1,1,12,59,59,0), accept_naive=True, utc=False)
- Traceback (most recent call last):
- ...
- ValueError: cannot generate a local timestamp from a naive datetime
diff --git a/dev-python/pyrfc3339/pyrfc3339-0.2.ebuild b/dev-python/pyrfc3339/pyrfc3339-0.2.ebuild
deleted file mode 100644
index 84b7d4121d63..000000000000
--- a/dev-python/pyrfc3339/pyrfc3339-0.2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=(python{2_7,3_4})
-
-inherit distutils-r1
-MY_PN=pyRFC3339
-
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Generates and parses RFC 3339 timestamps"
-HOMEPAGE="https://github.com/kurtraschke/pyRFC3339"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=("${FILESDIR}"/${P}-fixdoctests.patch)
-
-python_test() {
- nosetests || die
-}