summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 23:10:01 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 23:45:33 -0600
commitc5f2c1d36132b1888bfcd31c0a9f84d09514b880 (patch)
treeae5977df9eebe768b2ce4906f77359a0e4bc0420 /dev-python/pyroute2
parentdev-python/ryu: bup (diff)
downloadgentoo-c5f2c1d36132b1888bfcd31c0a9f84d09514b880.tar.gz
gentoo-c5f2c1d36132b1888bfcd31c0a9f84d09514b880.tar.bz2
gentoo-c5f2c1d36132b1888bfcd31c0a9f84d09514b880.zip
dev-python/pyroute2: initial commit
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/Manifest1
-rw-r--r--dev-python/pyroute2/metadata.xml19
-rw-r--r--dev-python/pyroute2/pyroute2-0.4.12.ebuild23
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyroute2/Manifest b/dev-python/pyroute2/Manifest
new file mode 100644
index 000000000000..fd600ffac587
--- /dev/null
+++ b/dev-python/pyroute2/Manifest
@@ -0,0 +1 @@
+DIST pyroute2-0.4.12.tar.gz 562555 SHA256 98e2e4841541aa180d14e301c5bfbc2d258e697e6dc76c88855cbf8b86375733 SHA512 d666c29cfb8da1e13748976030dc5ec153d2740f6df7f279a6e9fc4ec9b6ad60462c2a2b57905c4a4c8566da1de30dca0bb24b3b6c5a97bb729c074584270e2a WHIRLPOOL 7c26309bd6118bde2ee901a270b3494411f208695e924a96ec623c1a81c02f76e1d915bfc2620cfd21e7d2d935f97dfc963e5bf66de2523f3127b7033ca44e55
diff --git a/dev-python/pyroute2/metadata.xml b/dev-python/pyroute2/metadata.xml
new file mode 100644
index 000000000000..23c656d2c235
--- /dev/null
+++ b/dev-python/pyroute2/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pyroute2 is a pure Python netlink and Linux network configuration library.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pyroute2</remote-id>
+ <remote-id type="github">svinota/pyroute2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyroute2/pyroute2-0.4.12.ebuild b/dev-python/pyroute2/pyroute2-0.4.12.ebuild
new file mode 100644
index 000000000000..4c7d916a0037
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.4.12.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library."
+HOMEPAGE="https://github.com/rholder/retrying"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND=""