summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-07-15 11:43:19 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-07-15 11:43:19 +0200
commit92afdfbb5afc614c97cb1e3d0e593f8529dd65f7 (patch)
tree6fe85125cfebcc297bc0a1ecefdc8cd88d72b5dd /dev-python/pyserial
parentdev-python/flask-migrate: update HOMEPAGE. (diff)
downloadgentoo-92afdfbb5afc614c97cb1e3d0e593f8529dd65f7.tar.gz
gentoo-92afdfbb5afc614c97cb1e3d0e593f8529dd65f7.tar.bz2
gentoo-92afdfbb5afc614c97cb1e3d0e593f8529dd65f7.zip
dev-python/pyserial: version bump to 3.1.1.
Gentoo-Bug: https://bugs.gentoo.org/576164 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/pyserial')
-rw-r--r--dev-python/pyserial/Manifest1
-rw-r--r--dev-python/pyserial/pyserial-3.1.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyserial/Manifest b/dev-python/pyserial/Manifest
index 15b3cbaefdf6..aa457f6f98b5 100644
--- a/dev-python/pyserial/Manifest
+++ b/dev-python/pyserial/Manifest
@@ -1,2 +1,3 @@
DIST pyserial-2.6.tar.gz 116289 SHA256 049dbcda0cd475d3be903e721d60889ee2cc4ec3b62892a81ecef144196413ed SHA512 41682f8fafb6c5fa9642d3a0a3d6d0648101c38d157005f9c4e019e55d534953486072caf05647d8828b0e19c8259cc61cac856a570bf09904922ffd175fad2d WHIRLPOOL d632521d4687751f3056eda3ef254d603a7450d09457deed4d12136ee690d8af8d9aea1b8f8aebe9ec877a00bec5fa54933d2bff0cec281de0b676dde3d86e55
DIST pyserial-2.7.tar.gz 122081 SHA256 3542ec0838793e61d6224e27ff05e8ce4ba5a5c5cc4ec5c6a3e8d49247985477 SHA512 3fc8d9425a47ebcd37db1fcc58182854b48c9abd6642f35fba2d21458d864ae448105d704dc0d880832ba7516fa16f108f24363bd5fa9f083ea79a4ac614339b WHIRLPOOL ae6b4df86220617f7fbc1f1e4085a7e85dca645a6d84339163b40fc7a15f14b879ef7a729d3d23d0300f9ee04b21d6c24d13a791d520aef3f3ad141c6acd9b68
+DIST pyserial-3.1.1.tar.gz 147535 SHA256 d657051249ce3cbd0446bcfb2be07a435e1029da4d63f53ed9b4cdde7373364c SHA512 05b6f893454b187757c8d01c8d3951751ba93e87aafd474fa684a24198eed22f892181bcbab40101e74b25dae612116880690e800adedaf56a5c12775ed2b8d8 WHIRLPOOL d9d4b4894c94da9a357b27eb5e32766c0ff46cac751667f2f2195ca82ae2a2095a9df3ba219c10818faebd420912250a0dfcc6e86aedb7c4feaf6f553cdf4d52
diff --git a/dev-python/pyserial/pyserial-3.1.1.ebuild b/dev-python/pyserial/pyserial-3.1.1.ebuild
new file mode 100644
index 000000000000..295941c57c79
--- /dev/null
+++ b/dev-python/pyserial/pyserial-3.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Serial Port extension"
+HOMEPAGE="https://github.com/pyserial/pyserial https://pypi.python.org/pypi/pyserial"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Usual avoid d'loading un-needed objects.inv file
+PATCHES=( "${FILESDIR}"/mapping.patch )
+
+DOCS=( CHANGES.rst README.rst )
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}