summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-01 23:44:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 23:48:41 +0100
commitc10130eb6a60d8d753f495c13ce6981456d9500b (patch)
treeab589354839c4da95d4779a122739930b5daad5f /dev-python/pyserial
parentdev-python/pyserial: Add pypy3 love (diff)
downloadgentoo-c10130eb6a60d8d753f495c13ce6981456d9500b.tar.gz
gentoo-c10130eb6a60d8d753f495c13ce6981456d9500b.tar.bz2
gentoo-c10130eb6a60d8d753f495c13ce6981456d9500b.zip
dev-python/pyserial: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyserial')
-rw-r--r--dev-python/pyserial/pyserial-3.5-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyserial/pyserial-3.5-r1.ebuild b/dev-python/pyserial/pyserial-3.5-r1.ebuild
new file mode 100644
index 000000000000..605d44552619
--- /dev/null
+++ b/dev-python/pyserial/pyserial-3.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Serial Port extension"
+HOMEPAGE="https://github.com/pyserial/pyserial https://pypi.org/project/pyserial/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+DOCS=( CHANGES.rst README.rst )
+
+distutils_enable_sphinx documentation --no-autodoc
+
+python_test() {
+ "${EPYTHON}" test/run_all_tests.py loop:// -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}