summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-06 16:53:50 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-06 18:14:48 +0100
commite8b10d67b470a2c749473f5ba40a95f875dfe174 (patch)
treeb5b02f1f80871b158f2340f7f7607cf4347426f7 /dev-python/pyshark
parentdev-python/logbook: Add python3.5 support (diff)
downloadgentoo-e8b10d67b470a2c749473f5ba40a95f875dfe174.tar.gz
gentoo-e8b10d67b470a2c749473f5ba40a95f875dfe174.tar.bz2
gentoo-e8b10d67b470a2c749473f5ba40a95f875dfe174.zip
dev-python/pyshark: Add py3 support
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=570578 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyshark')
-rw-r--r--dev-python/pyshark/pyshark-0.3.6.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/pyshark/pyshark-0.3.6.ebuild b/dev-python/pyshark/pyshark-0.3.6.ebuild
index 752b5295a71f..e9cb16034b26 100644
--- a/dev-python/pyshark/pyshark-0.3.6.ebuild
+++ b/dev-python/pyshark/pyshark-0.3.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1 eutils
@@ -19,7 +19,8 @@ IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
# See pyshark.egg-info/requires.txt
-RDEPEND="dev-python/py[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
dev-python/logbook[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/trollius[${PYTHON_USEDEP}]