summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyside
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyside')
-rw-r--r--dev-python/pyside/Manifest1
-rw-r--r--dev-python/pyside/files/qgtkstyle-1.2.2.patch33
-rw-r--r--dev-python/pyside/files/rpath.cmake10
-rw-r--r--dev-python/pyside/metadata.xml20
-rw-r--r--dev-python/pyside/pyside-1.2.2-r1.ebuild142
-rw-r--r--dev-python/pyside/pyside-1.2.2.ebuild140
6 files changed, 346 insertions, 0 deletions
diff --git a/dev-python/pyside/Manifest b/dev-python/pyside/Manifest
new file mode 100644
index 000000000000..f6874fbfc8f7
--- /dev/null
+++ b/dev-python/pyside/Manifest
@@ -0,0 +1 @@
+DIST pyside-qt4.8+1.2.2.tar.bz2 3765472 SHA256 a1a9df746378efe52211f1a229f77571d1306fb72830bbf73f0d512ed9856ae1 SHA512 3a1d46c48ac71c3b138e1dc398d1d2a87aff558eace275303e233f78d03e32c6d53cf390db5e7112f44da9b17aa88ed16a30f6f83b2073c1f494e61b962e4c46 WHIRLPOOL 5ac5eb5032fbc791e955eb0b2b0f1443e43867408a7b6c41854db1cab466714509c035e8271f5b0b3078309be001d5bcea498601b97f540e7775e87bdbc1c0c8
diff --git a/dev-python/pyside/files/qgtkstyle-1.2.2.patch b/dev-python/pyside/files/qgtkstyle-1.2.2.patch
new file mode 100644
index 000000000000..d782276aba68
--- /dev/null
+++ b/dev-python/pyside/files/qgtkstyle-1.2.2.patch
@@ -0,0 +1,33 @@
+diff --git a/PySide/QtGui/CMakeLists.txt b/PySide/QtGui/CMakeLists.txt
+index 6e14706..bd60775 100644
+--- a/PySide/QtGui/CMakeLists.txt
++++ b/PySide/QtGui/CMakeLists.txt
+@@ -71,7 +71,6 @@ set(QtGui_OPTIONAL_SRC )
+ set(QtGui_DROPPED_ENTRIES )
+ check_qt_class(QtGui QAbstractPageSetupDialog QtGui_OPTIONAL_SRC QtGui_DROPPED_ENTRIES)
+ check_qt_class(QtGui QAbstractPrintDialog QtGui_OPTIONAL_SRC QtGui_DROPPED_ENTRIES)
+-check_qt_class(QtGui QGtkStyle QtGui_OPTIONAL_SRC QtGui_DROPPED_ENTRIES)
+ check_qt_class(QtGui QPageSetupDialog QtGui_OPTIONAL_SRC QtGui_DROPPED_ENTRIES)
+ check_qt_class(QtGui QPrintDialog QtGui_OPTIONAL_SRC QtGui_DROPPED_ENTRIES)
+ check_qt_class(QtGui QPrintEngine QtGui_OPTIONAL_SRC QtGui_DROPPED_ENTRIES)
+diff --git a/PySide/QtGui/typesystem_gui_common.xml b/PySide/QtGui/typesystem_gui_common.xml
+index 711d7cc..954aa54 100644
+--- a/PySide/QtGui/typesystem_gui_common.xml
++++ b/PySide/QtGui/typesystem_gui_common.xml
+@@ -6996,16 +6996,6 @@
+ <modify-function signature="exec()" rename="exec_" allow-thread="yes" />
+ </object-type>
+
+- <object-type name="QGtkStyle">
+- <modify-function signature="standardPixmap(QStyle::StandardPixmap,const QStyleOption*,const QWidget*)const">
+- <modify-argument index="2">
+- <replace-default-expression with="0"/>
+- </modify-argument>
+- <modify-argument index="3">
+- <replace-default-expression with="0"/>
+- </modify-argument>
+- </modify-function>
+- </object-type>
+
+ <object-type name="QPageSetupDialog">
+ <enum-type name="PageSetupDialogOption" flags="PageSetupDialogOptions"/>
diff --git a/dev-python/pyside/files/rpath.cmake b/dev-python/pyside/files/rpath.cmake
new file mode 100644
index 000000000000..b896c8789185
--- /dev/null
+++ b/dev-python/pyside/files/rpath.cmake
@@ -0,0 +1,10 @@
+# use, i.e. don't skip the full RPATH for the build tree
+SET(CMAKE_SKIP_BUILD_RPATH FALSE)
+
+# when building, don't use the install RPATH already
+# (but later on when installing)
+SET(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+
+# add the automatically determined parts of the RPATH
+# which point to directories outside the build tree to the install RPATH
+SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
diff --git a/dev-python/pyside/metadata.xml b/dev-python/pyside/metadata.xml
new file mode 100644
index 000000000000..186ae3f8e09d
--- /dev/null
+++ b/dev-python/pyside/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <use>
+ <flag name="X">Build QtGui and QtTest modules</flag>
+ <flag name="declarative">Build QtDeclarative module</flag>
+ <flag name="designer">Build QtDesigner and QtUiTools modules</flag>
+ <flag name="help">Build QtHelp module</flag>
+ <flag name="multimedia">Build QtMultimedia module</flag>
+ <flag name="opengl">Build QtOpenGL module</flag>
+ <flag name="phonon">Build phonon module</flag>
+ <flag name="script">Build QtScript module</flag>
+ <flag name="scripttools">Build QtScriptTools module</flag>
+ <flag name="sql">Build QtSql module</flag>
+ <flag name="svg">Build QtSvg module</flag>
+ <flag name="webkit">Build QtWebKit module</flag>
+ <flag name="xmlpatterns">Build QtXmlPatterns module</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-python/pyside/pyside-1.2.2-r1.ebuild b/dev-python/pyside/pyside-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..b2f67938ea2c
--- /dev/null
+++ b/dev-python/pyside/pyside-1.2.2-r1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit cmake-utils multilib python-r1 virtualx
+
+MY_P="${PN}-qt4.8+${PV}"
+
+DESCRIPTION="Python bindings for the Qt framework"
+HOMEPAGE="http://qt-project.org/wiki/PySide"
+SRC_URI="http://download.qt-project.org/official_releases/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+
+IUSE="X declarative designer help multimedia opengl phonon script scripttools sql svg test webkit xmlpatterns"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ declarative? ( X )
+ designer? ( X )
+ help? ( X )
+ multimedia? ( X )
+ opengl? ( X )
+ phonon? ( X )
+ scripttools? ( X script )
+ sql? ( X )
+ svg? ( X )
+ test? ( X )
+ webkit? ( X )
+"
+
+# Minimal supported version of Qt.
+QT_PV="4.8.5:4"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/shiboken-${PV}[${PYTHON_USEDEP}]
+ >=dev-qt/qtcore-${QT_PV}
+ X? (
+ >=dev-qt/qtgui-${QT_PV}[accessibility]
+ >=dev-qt/qttest-${QT_PV}
+ )
+ declarative? ( >=dev-qt/qtdeclarative-${QT_PV} )
+ designer? ( >=dev-qt/designer-${QT_PV} )
+ help? ( >=dev-qt/qthelp-${QT_PV} )
+ multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
+ opengl? ( >=dev-qt/qtopengl-${QT_PV} )
+ phonon? ( || (
+ media-libs/phonon[qt4(+)]
+ >=dev-qt/qtphonon-${QT_PV}
+ ) )
+ script? ( >=dev-qt/qtscript-${QT_PV} )
+ sql? ( >=dev-qt/qtsql-${QT_PV} )
+ svg? ( >=dev-qt/qtsvg-${QT_PV}[accessibility] )
+ webkit? ( >=dev-qt/qtwebkit-${QT_PV} )
+ xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtgui-${QT_PV}
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ # Fix generated pkgconfig file to require the shiboken
+ # library suffixed with the correct python version.
+ sed -i -e '/^Requires:/ s/shiboken$/&@SHIBOKEN_PYTHON_SUFFIX@/' \
+ libpyside/pyside.pc.in || die
+
+ if use prefix; then
+ cp "${FILESDIR}"/rpath.cmake . || die
+ sed -i -e '1iinclude(rpath.cmake)' CMakeLists.txt || die
+ fi
+
+ epatch "${FILESDIR}/qgtkstyle-${PV}.patch" # bug 530764
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ $(cmake-utils_use_disable X QtGui)
+ $(cmake-utils_use_disable X QtTest)
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable designer QtDesigner)
+ $(cmake-utils_use_disable designer QtUiTools)
+ $(cmake-utils_use_disable help QtHelp)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_disable phonon)
+ $(cmake-utils_use_disable script QtScript)
+ $(cmake-utils_use_disable scripttools QtScriptTools)
+ $(cmake-utils_use_disable sql QtSql)
+ $(cmake-utils_use_disable svg QtSvg)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ $(cmake-utils_use_disable xmlpatterns QtXmlPatterns)
+ )
+
+ if use phonon && has_version "media-libs/phonon[qt4(+)]"; then
+ # bug 475786
+ mycmakeargs+=(
+ -DQT_PHONON_INCLUDE_DIR="${EPREFIX}/usr/include/phonon"
+ -DQT_PHONON_LIBRARY_RELEASE="${EPREFIX}/usr/$(get_libdir)/libphonon.so"
+ )
+ fi
+
+ configuration() {
+ local mycmakeargs=(
+ -DPYTHON_SUFFIX="-${EPYTHON}"
+ "${mycmakeargs[@]}"
+ )
+ cmake-utils_src_configure
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+ local PYTHONDONTWRITEBYTECODE
+ export PYTHONDONTWRITEBYTECODE
+
+ VIRTUALX_COMMAND="cmake-utils_src_test" python_foreach_impl virtualmake
+}
+
+src_install() {
+ installation() {
+ cmake-utils_src_install
+ mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+ }
+ python_foreach_impl installation
+}
diff --git a/dev-python/pyside/pyside-1.2.2.ebuild b/dev-python/pyside/pyside-1.2.2.ebuild
new file mode 100644
index 000000000000..c2ff4b9e854c
--- /dev/null
+++ b/dev-python/pyside/pyside-1.2.2.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit cmake-utils multilib python-r1 virtualx
+
+MY_P="${PN}-qt4.8+${PV}"
+
+DESCRIPTION="Python bindings for the Qt framework"
+HOMEPAGE="http://qt-project.org/wiki/PySide"
+SRC_URI="http://download.qt-project.org/official_releases/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+
+IUSE="X declarative designer help multimedia opengl phonon script scripttools sql svg test webkit xmlpatterns"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ declarative? ( X )
+ designer? ( X )
+ help? ( X )
+ multimedia? ( X )
+ opengl? ( X )
+ phonon? ( X )
+ scripttools? ( X script )
+ sql? ( X )
+ svg? ( X )
+ test? ( X )
+ webkit? ( X )
+"
+
+# Minimal supported version of Qt.
+QT_PV="4.8.5:4"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/shiboken-${PV}[${PYTHON_USEDEP}]
+ >=dev-qt/qtcore-${QT_PV}
+ X? (
+ >=dev-qt/qtgui-${QT_PV}[accessibility]
+ >=dev-qt/qttest-${QT_PV}
+ )
+ declarative? ( >=dev-qt/qtdeclarative-${QT_PV} )
+ designer? ( >=dev-qt/designer-${QT_PV} )
+ help? ( >=dev-qt/qthelp-${QT_PV} )
+ multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
+ opengl? ( >=dev-qt/qtopengl-${QT_PV} )
+ phonon? ( || (
+ media-libs/phonon[qt4(+)]
+ >=dev-qt/qtphonon-${QT_PV}
+ ) )
+ script? ( >=dev-qt/qtscript-${QT_PV} )
+ sql? ( >=dev-qt/qtsql-${QT_PV} )
+ svg? ( >=dev-qt/qtsvg-${QT_PV}[accessibility] )
+ webkit? ( >=dev-qt/qtwebkit-${QT_PV} )
+ xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtgui-${QT_PV}
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ # Fix generated pkgconfig file to require the shiboken
+ # library suffixed with the correct python version.
+ sed -i -e '/^Requires:/ s/shiboken$/&@SHIBOKEN_PYTHON_SUFFIX@/' \
+ libpyside/pyside.pc.in || die
+
+ if use prefix; then
+ cp "${FILESDIR}"/rpath.cmake . || die
+ sed -i -e '1iinclude(rpath.cmake)' CMakeLists.txt || die
+ fi
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ $(cmake-utils_use_disable X QtGui)
+ $(cmake-utils_use_disable X QtTest)
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable designer QtDesigner)
+ $(cmake-utils_use_disable designer QtUiTools)
+ $(cmake-utils_use_disable help QtHelp)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_disable phonon)
+ $(cmake-utils_use_disable script QtScript)
+ $(cmake-utils_use_disable scripttools QtScriptTools)
+ $(cmake-utils_use_disable sql QtSql)
+ $(cmake-utils_use_disable svg QtSvg)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ $(cmake-utils_use_disable xmlpatterns QtXmlPatterns)
+ )
+
+ if use phonon && has_version "media-libs/phonon[qt4(+)]"; then
+ # bug 475786
+ mycmakeargs+=(
+ -DQT_PHONON_INCLUDE_DIR="${EPREFIX}/usr/include/phonon"
+ -DQT_PHONON_LIBRARY_RELEASE="${EPREFIX}/usr/$(get_libdir)/libphonon.so"
+ )
+ fi
+
+ configuration() {
+ local mycmakeargs=(
+ -DPYTHON_SUFFIX="-${EPYTHON}"
+ "${mycmakeargs[@]}"
+ )
+ cmake-utils_src_configure
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+ local PYTHONDONTWRITEBYTECODE
+ export PYTHONDONTWRITEBYTECODE
+
+ VIRTUALX_COMMAND="cmake-utils_src_test" python_foreach_impl virtualmake
+}
+
+src_install() {
+ installation() {
+ cmake-utils_src_install
+ mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+ }
+ python_foreach_impl installation
+}