summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-09 10:35:55 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-09 11:49:34 +0200
commit5f6b65bef0516785da1cd12ccb44a3a5525768f2 (patch)
treeed5a0de3ddbd80abd277a29e8df74dd8c8867eeb /dev-python/pytest-xdist
parentdev-python/process-tests: Fix license (diff)
downloadgentoo-5f6b65bef0516785da1cd12ccb44a3a5525768f2.tar.gz
gentoo-5f6b65bef0516785da1cd12ccb44a3a5525768f2.tar.bz2
gentoo-5f6b65bef0516785da1cd12ccb44a3a5525768f2.zip
dev-python/pytest-xdist: New package, ebuild written by me
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/metadata.xml13
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
new file mode 100644
index 000000000000..2a22275319ee
--- /dev/null
+++ b/dev-python/pytest-xdist/Manifest
@@ -0,0 +1 @@
+DIST pytest-xdist-1.13.1.tar.gz 110007 SHA256 4382d7a944c1e2b1dc17fee3fd3575495fb10236a3b6e95cc6955db04984bc3c SHA512 3bb295c0afbcb0f238bdd41dfd1a395f0ba16b8151643aecc25aae13ac7c58d36d26ff4bab197673a9679d1f3436acd05b5ff50107b3128e647de892a6d04e3f WHIRLPOOL 643b23c755eb43c7b6965e588b58547c9ef63d3c225cddb97868c659ab3234bc6bc204575bc48c7f18a498cb0e595b8550928ba92ec5945a936e959f773504b3
diff --git a/dev-python/pytest-xdist/metadata.xml b/dev-python/pytest-xdist/metadata.xml
new file mode 100644
index 000000000000..9ff7a6400d92
--- /dev/null
+++ b/dev-python/pytest-xdist/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pxml</remote-id>
+ <remote-id type="github">metagriffin/pxml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
new file mode 100644
index 000000000000..38cb802e8896
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-xdist https://bitbucket.org/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "