summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-07-31 16:24:08 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-07-31 16:47:03 +0200
commit4db8e34a3c9bd9892980fd8f344d74415e360b6d (patch)
treed3f4c393eb2968de82b59c2d7fe49255e8b56ebf /dev-python/python-afl
parentdev-db/mongodb: drop 3.2 old (diff)
downloadgentoo-4db8e34a3c9bd9892980fd8f344d74415e360b6d.tar.gz
gentoo-4db8e34a3c9bd9892980fd8f344d74415e360b6d.tar.bz2
gentoo-4db8e34a3c9bd9892980fd8f344d74415e360b6d.zip
dev-python/python-afl: Version bump to 0.6.1
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/python-afl')
-rw-r--r--dev-python/python-afl/Manifest1
-rw-r--r--dev-python/python-afl/python-afl-0.6.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-afl/Manifest b/dev-python/python-afl/Manifest
index 55ea58f882ae..c96891a531d0 100644
--- a/dev-python/python-afl/Manifest
+++ b/dev-python/python-afl/Manifest
@@ -1 +1,2 @@
+DIST python-afl-0.6.1.tar.gz 14795 SHA256 3dc79ae0018a00e936ce2e5ee5ceb2634337103e2cc83bdd78029404b4dca91d SHA512 25662ae96db23560ab0f7df1468f1a4737f8f68853bed75cfcfe6112a6fac110501c66941402f35686d6b96a6d124a2aeeaed79052d618583843528cb3eee3aa WHIRLPOOL 1035d12cbfc0eeffdbb6d824be4ed92a66c8416f4b48e1ffed0c5c600fa076b54ba428942afb4fc736c461b7e2f92e4aeb34be29b2058e84bc65240a35166f59
DIST python-afl-0.6.tar.gz 14641 SHA256 14dc3a0a7fafddacefc209205795785cff8f5852f85732564814ea4eb2d9ee37 SHA512 ecbfd097645be5a97f1c3523d5c9d18d63a5e27c633cd5bc9e7c0ef1e10b55982fc1a8d698a27b66bb3b4eb3b2d21956449aee24ea01df9d626b80a1d9d430b6 WHIRLPOOL c140f351573a48c1dc618e786f9745d0ea63b527c3d4b1379c89432d058c775fb381999f41772df08bae1314b13f34e63eb8f07aa687ec8bad1a1b0971ce99ae
diff --git a/dev-python/python-afl/python-afl-0.6.1.ebuild b/dev-python/python-afl/python-afl-0.6.1.ebuild
new file mode 100644
index 000000000000..1cf0d8b03aa3
--- /dev/null
+++ b/dev-python/python-afl/python-afl-0.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Enables American fuzzy lop fork server and instrumentation for pure-Python code"
+HOMEPAGE="https://github.com/jwilk/python-afl http://jwilk.net/software/python-afl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="app-forensics/afl"
+DEPEND=">=dev-python/cython-0.19[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ PATH="${PATH}:." nosetests --verbose || die
+}