summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-cluster
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-cluster')
-rw-r--r--dev-python/python-cluster/Manifest1
-rw-r--r--dev-python/python-cluster/files/python-cluster-python3.patch37
-rw-r--r--dev-python/python-cluster/metadata.xml9
-rw-r--r--dev-python/python-cluster/python-cluster-1.2.2.ebuild24
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/python-cluster/Manifest b/dev-python/python-cluster/Manifest
new file mode 100644
index 000000000000..85498a6d8488
--- /dev/null
+++ b/dev-python/python-cluster/Manifest
@@ -0,0 +1 @@
+DIST cluster-1.2.2.tar.gz 44074 SHA256 7d62faf24fa08ef13f71013e9f624c528b12f0d1e6ab58c4bd26b5874d3163d8 SHA512 02600fa1fccdb07251bea83ab81908c22968fcfd4d6ccf382a75ab43117ee8ecc4385f7666f272d1e6cfc0634f7e15778635b50fde572773e564604c981e75cf WHIRLPOOL c5ee445f0b51b5af4e927049ef8cdd5decac3cef73f23d909b4b38b9b896100fffb531af7bf4ac059aae19ca07583d1b60e0e79cb874b718033474bd148d9731
diff --git a/dev-python/python-cluster/files/python-cluster-python3.patch b/dev-python/python-cluster/files/python-cluster-python3.patch
new file mode 100644
index 000000000000..3294d70aa71f
--- /dev/null
+++ b/dev-python/python-cluster/files/python-cluster-python3.patch
@@ -0,0 +1,37 @@
+--- cluster.py.old 2010-10-01 14:41:55.000000000 +0200
++++ cluster.py 2010-10-01 14:42:32.000000000 +0200
+@@ -130,7 +130,7 @@
+ format = " %%%is |" % maxlen
+ format = "|" + format*colcount
+ for row in list:
+- print format % tuple(row)
++ print (format % tuple(row))
+
+ def magnitude(a):
+ "calculates the magnitude of a vecor"
+@@ -239,12 +239,12 @@
+ """
+ Pretty-prints this cluster. Useful for debuging
+ """
+- print depth*" " + "[level %s]" % self.__level
++ print (depth*" " + "[level %s]" % self.__level)
+ for item in self.__items:
+ if isinstance(item, Cluster):
+ item.display(depth+1)
+ else:
+- print depth*" "+"%s" % item
++ print (depth*" "+"%s" % item)
+
+ def topology(self):
+ """
+--- cluster.py.old 2010-10-01 14:48:54.000000000 +0200
++++ cluster.py 2010-10-01 14:49:21.000000000 +0200
+@@ -429,7 +429,7 @@
+ elif method == 'uclus':
+ self.linkage = self.uclusDistance
+ else:
+- raise ValueError, 'distance method must be one of single, complete, average of uclus'
++ raise ValueError('distance method must be one of single, complete, average of uclus')
+
+ def uclusDistance(self, x, y):
+ """
diff --git a/dev-python/python-cluster/metadata.xml b/dev-python/python-cluster/metadata.xml
new file mode 100644
index 000000000000..ae07547fa10b
--- /dev/null
+++ b/dev-python/python-cluster/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">cluster</remote-id>
+ <remote-id type="github">exhuma/python-cluster</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-cluster/python-cluster-1.2.2.ebuild b/dev-python/python-cluster/python-cluster-1.2.2.ebuild
new file mode 100644
index 000000000000..92f38fc5faa9
--- /dev/null
+++ b/dev-python/python-cluster/python-cluster-1.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Allows grouping a list of arbitrary objects into related groups (clusters)"
+HOMEPAGE="https://github.com/exhuma/python-cluster"
+SRC_URI="mirror://pypi/c/cluster/cluster-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/cluster-${PV}"
+
+python_test() {
+ "${PYTHON}" test.py || die "Testing failed with ${EPYTHON}"
+}