summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-12-22 13:45:03 -0800
committerZac Medico <zmedico@gentoo.org>2015-12-22 13:48:57 -0800
commit0882d360d62537da96670104803d16fd45900008 (patch)
treed3ebb1e693531cdca43fc4b3b4b5fee19f7fc3ce /dev-python/python-engineio
parentnet-analyzer/masscan: Fix compiling with gcc-5 (bug #569246 by Toralf Förster). (diff)
downloadgentoo-0882d360d62537da96670104803d16fd45900008.tar.gz
gentoo-0882d360d62537da96670104803d16fd45900008.tar.bz2
gentoo-0882d360d62537da96670104803d16fd45900008.zip
dev-python/python-engineio: add pypy and pypy3 to PYTHON_COMPAT
Also, remove test dependencies which are unsatisfiable due to this change. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/python-engineio-0.8.1.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/dev-python/python-engineio/python-engineio-0.8.1.ebuild b/dev-python/python-engineio/python-engineio-0.8.1.ebuild
index 6f1d6174d395..53e64a8376b0 100644
--- a/dev-python/python-engineio/python-engineio-0.8.1.ebuild
+++ b/dev-python/python-engineio/python-engineio-0.8.1.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
inherit distutils-r1
@@ -18,12 +18,7 @@ IUSE="test"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- )"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
# pypi tarball does not contain tests
RESTRICT="test"